Bug 21504 - Acid3: Safari pauses at 69/100 if a menu is open
Summary: Acid3: Safari pauses at 69/100 if a menu is open
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://acid3.acidtests.org/
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-09 12:25 PDT by Ian 'Hixie' Hickson
Modified: 2008-10-09 16:33 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian 'Hixie' Hickson 2008-10-09 12:25:02 PDT
STEPS TO REPRODUCE
1. Open http://acid3.acidtests.org/
2. Immediately open a menu (e.g. the View menu).
3. Wait.

ACTUAL RESULTS
Test stops at 69/100 until you release the menu.

EXPECTED RESULTS
100/100. Menu should have no effect on JS execution or anything.
Comment 1 Gavin Sherlock 2008-10-09 12:37:12 PDT
I found that it I keep the menu open, it eventually continues to test 93, but never gets any further, even if I then release the menu.  The failures are listed as:

Failed 7 tests.
Test 00 passed, but took 161ms (less than 30fps)
Test 07 passed, but took 216ms (less than 30fps)
Test 69 failed: timeout -- could be a networking issue
Test 74 failed: getSVGDocument failed for <iframe> referencing an svg document.
Test 75 failed: Result of expression 'svg.setCurrentTime' [undefined] is not a function.
Test 76 failed: expected '0' but got '100' - Incorrect animVal value after svg animation.
Test 77 failed: expected '3' but got '0' - getNumberOfChars returned incorrect string length.
Test 78 failed: expected '90' but got '0' - getRotationOfChar(0) failed.
Test 80 failed: Script in XHTML didn't execute
Total elapsed time: 17.80s

Tested with r37012 on 10.5.5
Comment 2 Mark Rowe (bdash) 2008-10-09 16:29:17 PDT
This was fixed by <http://trac.webkit.org/changeset/30778>.  It requires an updated version of Safari for the fix to take effect due to it being an opt-in check, to avoid unexpected behaviour in other WebKit-using applications.