Bug 214898 - Web Inspector: REGRESSION(r255396): Audit: button to exit edit mode in main content area is missing border
Summary: Web Inspector: REGRESSION(r255396): Audit: button to exit edit mode in main c...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Brian Burg
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-07-28 14:42 PDT by Devin Rousso
Modified: 2020-07-28 21:31 PDT (History)
4 users (show)

See Also:


Attachments
Patch (1.99 KB, patch)
2020-07-28 16:00 PDT, Brian Burg
drousso: review+
bburg: commit-queue?
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Rousso 2020-07-28 14:42:11 PDT
# STEPS TO REPRODUCE
1. inspect any page
2. go to the Audit Tab
3. enter Edit mode from the navigation sidebar
  => the Done button in the main content area is missing a border
Comment 1 Radar WebKit Bug Importer 2020-07-28 14:42:26 PDT
<rdar://problem/66238391>
Comment 2 Devin Rousso 2020-07-28 15:10:37 PDT
I'm pretty sure this was caused by the following change from r255396 <https://webkit.org/b/205434>:
```
-.message-text-view .navigation-item-help .navigation-bar > .item {
+.navigation-item-help > .navigation-bar > .item {
```
Comment 3 Brian Burg 2020-07-28 16:00:53 PDT
Created attachment 405425 [details]
Patch
Comment 4 Devin Rousso 2020-07-28 16:12:38 PDT
Comment on attachment 405425 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=405425&action=review

r=me

> Source/WebInspectorUI/UserInterface/Views/Main.css:239
>  .navigation-item-help > .navigation-bar > .item {

we could also adjust `WI.createNavigationItemHelp` to always expect `console.assert(navigationItem instanceof WI.ButtonNavigationItem);` so that we could add `.button` to the CSS since `.text-only` only exists for `WI.ButtonNavigationItem`

> Source/WebInspectorUI/UserInterface/Views/Main.css:246
> +.navigation-item-help > .navigation-bar > .item:not(.text-only) {

ditto (:239)

> Source/WebInspectorUI/UserInterface/Views/Main.css:250
> +.navigation-item-help > .navigation-bar > .item.text-only {

ditto (:239)

> Source/WebInspectorUI/UserInterface/Views/Main.css:251
> +    border: solid 1px var(--border-color);

It's a bit odd that we have the same CSS property repeated twice exactly as is for two rules that should both match the same thing.  Perhaps you could add a comment above it explaining that this is necessary due to the specificity of `.navigation-bar .item.button.text-only`?
Comment 5 Brian Burg 2020-07-28 21:31:35 PDT
Committed r265027: <https://trac.webkit.org/changeset/265027>