Bug 214683 - [ macOS wk2 debug ] imported/w3c/web-platform-tests/media-source/mediasource-changetype-play-implicit.html is a flaky failure (harness timeout)
Summary: [ macOS wk2 debug ] imported/w3c/web-platform-tests/media-source/mediasource-...
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Mac Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-07-23 05:15 PDT by Karl Rackler
Modified: 2020-07-23 17:00 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Rackler 2020-07-23 05:15:39 PDT
Description:
imported/w3c/web-platform-tests/media-source/mediasource-changetype-play-implicit.html

This issue started approximately 07/14/20 since the test was introduced and is a flaky failure daily since.

History:
https://results.webkit.org/?suite=layout-tests&test=imported%2Fw3c%2Fweb-platform-tests%2Fmedia-source%2Fmediasource-changetype-play-implicit.html&flavor=wk2&style=debug&platform=mac&limit=50000

Diff:
--- /Volumes/Data/slave/catalina-debug-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/media-source/mediasource-changetype-play-implicit-expected.txt
+++ /Volumes/Data/slave/catalina-debug-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/media-source/mediasource-changetype-play-implicit-actual.txt
@@ -1,8 +1,10 @@
+
+Harness Error (TIMEOUT), message = null
 
 FAIL Check if browser supports enough test media types and pairs of audio-only or video-only media with same bytestream format assert_true: Browser doesn't support at least 2 audio-only or 2 video-only test media with same bytestream format expected true got false
 PASS Test audio-only implicit changeType for audio/mp4; codecs="mp4a.40.2" <-> audio/mp4; codecs="mp4a.40.2" 
 PASS Test audio-only implicit changeType for audio/mp4; codecs="mp4a.40.2" <-> audio/mp4; codecs="mp4a.40.2" (using types without codecs parameters for addSourceBuffer) 
 PASS Test audio-only implicit changeType for audio/mpeg <-> audio/mpeg 
-PASS Test video-only implicit changeType for video/mp4; codecs="avc1.4D4001" <-> video/mp4; codecs="avc1.4D4001" 
+TIMEOUT Test video-only implicit changeType for video/mp4; codecs="avc1.4D4001" <-> video/mp4; codecs="avc1.4D4001" Test timed out
 PASS Test video-only implicit changeType for video/mp4; codecs="avc1.4D4001" <-> video/mp4; codecs="avc1.4D4001" (using types without codecs parameters for addSourceBuffer)
Comment 1 Radar WebKit Bug Importer 2020-07-23 05:16:12 PDT
<rdar://problem/65986787>
Comment 2 Karl Rackler 2020-07-23 05:22:36 PDT
I have marked these tests as failing while this issue is investigated.
https://trac.webkit.org/changeset/264756/webkit