Bug 214666 - [Cocoa|WebM] Decode error when seeking
Summary: [Cocoa|WebM] Decode error when seeking
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jer Noble
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-07-22 17:18 PDT by Jer Noble
Modified: 2020-07-22 20:01 PDT (History)
3 users (show)

See Also:


Attachments
Patch (2.75 KB, patch)
2020-07-22 17:22 PDT, Jer Noble
eric.carlson: review+
Details | Formatted Diff | Diff
Patch for landing (2.75 KB, patch)
2020-07-22 18:07 PDT, Jer Noble
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jer Noble 2020-07-22 17:18:10 PDT
[Cocoa|WebM] Decode error when seeking
Comment 1 Jer Noble 2020-07-22 17:22:13 PDT
<rdar://problem/65961804>
Comment 2 Jer Noble 2020-07-22 17:22:32 PDT
Created attachment 404999 [details]
Patch
Comment 3 Eric Carlson 2020-07-22 18:03:36 PDT
Comment on attachment 404999 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=404999&action=review

> Source/WebCore/ChangeLog:8
> +        A decoder error is hit when seeking because we think all samples coming out of the SourceBufferParserWebM is a sync-sample.

There is a tense problem here: "all samples ... is a sync-sample"
Comment 4 Jer Noble 2020-07-22 18:07:05 PDT
Created attachment 405003 [details]
Patch for landing
Comment 5 EWS 2020-07-22 20:01:29 PDT
Committed r264742: <https://trac.webkit.org/changeset/264742>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 405003 [details].