Bug 21384 - Spell checking not working in designmode iframes (rich text editors)
Summary: Spell checking not working in designmode iframes (rich text editors)
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-05 08:27 PDT by Cacycle
Modified: 2008-10-06 05:43 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cacycle 2008-10-05 08:27:16 PDT
The spell checker is broken for iframes in designmode (rich text editors). This seems to be a big problem (and deal breaker) for users of JavaScript editors (such as the Wikipedia editor wikEd http://en.wikipedia.org/wiki/User:Cacycle/wikEd).

Mozilla-based browsers such as Firefox and SeaMonkey applied spell checking to textareas as well as iframes in designmode from the very beginning.

As a simple test case you can go to http://www.kevinroth.com/rte/demo.htm and type some random letters. No red underlines will appear as they would in normal textareas.
Comment 1 Mark Rowe (bdash) 2008-10-05 16:19:06 PDT
This works correctly for me in both Safari 3.1.2 and with the latest nightly build on Mac and Windows.  Please be sure that you have not unchecked the "Check Spelling While Typing" item in the "Spelling and Grammar" context menu item.
Comment 2 Cacycle 2008-10-05 17:03:43 PDT
Unfortunately I do not have a Mac to test Safari and I had to rely on a bug report from one of my users who reported a functioning spell checking in textareas, but not in editmode iframes, suggesting that the cause of the problem is not that "Check Spelling While Typing" setting.

I will ask him for his Safari version number and will report back here.

I have also replicated the problem myself in Google Chrome (which uses an older Webkit version and does not have user accessible options to turn spell checking on or off).

Does it also work when you use the wikEd gadget for editing Wikipedia (register a Wikipedia account, go to Preferences > Gadgets and check wikEd, and edit an article).
Comment 3 Mark Rowe (bdash) 2008-10-05 17:25:42 PDT
If you have Windows you can easily test Safari yourself.
Comment 4 Cacycle 2008-10-05 18:37:47 PDT
Yes, I have just figured that out and it actually works under Safari 3.1.2 under Windows XP when tested with the rich text editor wikEd.
Comment 5 Cacycle 2008-10-06 05:43:38 PDT
The user insists that the problem is real and that the spell checker is enabled. His user agent is:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_5; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1.

(The bug discussions can be found here:
http://en.wikipedia.org/wiki/User_talk:Maury_Markowitz#Spell_checker_under_wikEd_-_need_browser_version and http://en.wikipedia.org/wiki/User_talk:Cacycle/wikEd#Interferes_with_spell_checkers.3F)