WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
213746
[iOS 14] A couple of tests in editing/selection/ios fail after <
rdar://problem/60978283
>
https://bugs.webkit.org/show_bug.cgi?id=213746
Summary
[iOS 14] A couple of tests in editing/selection/ios fail after <rdar://proble...
Wenson Hsieh
Reported
2020-06-29 11:57:15 PDT
More work towards <
rdar://problem/64808138
> These two tests are: • editing/selection/ios/select-text-in-existing-selection.html • editing/selection/ios/selection-extends-into-overflow-area.html
Attachments
Patch
(8.95 KB, patch)
2020-06-29 14:41 PDT
,
Wenson Hsieh
hi
: review+
Details
Formatted Diff
Diff
Patch for landing
(9.12 KB, patch)
2020-06-29 16:09 PDT
,
Wenson Hsieh
no flags
Details
Formatted Diff
Diff
View All
Add attachment
proposed patch, testcase, etc.
Wenson Hsieh
Comment 1
2020-06-29 14:41:43 PDT
Created
attachment 403116
[details]
Patch
Devin Rousso
Comment 2
2020-06-29 15:12:33 PDT
Comment on
attachment 403116
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=403116&action=review
r=me, with some NITs
> LayoutTests/editing/selection/ios/select-text-in-existing-selection.html:28 > +editor = document.querySelector("div[contenteditable]"); > +target = document.getElementById("target");
NIT: `let`?
> LayoutTests/resources/ui-helper.js:135 > + const x = element.offsetLeft + element.offsetWidth / 2; > + const y = element.offsetTop + element.offsetHeight / 2;
NIT: I'd add parenthesis around the `/ 2` to avoid ambiguity/complexity while reading
> LayoutTests/resources/ui-helper.js:1103 > + new Promise(resolve => target.addEventListener(eventName, e => {
NIT: for readability, I usually avoid using inlined arrow functions unless I am intentionally using the implicit return value ``` new Promise((eventListenerResolve) => { target.addEventListener(eventName, (e) => { event = e; eventListenerResolve(); }, {once: true}) }), ``` NIT: I'd also recommend using a different variable name other than `resolve` to avoid shadowing
Wenson Hsieh
Comment 3
2020-06-29 16:05:30 PDT
Comment on
attachment 403116
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=403116&action=review
>> LayoutTests/editing/selection/ios/select-text-in-existing-selection.html:28 >> +target = document.getElementById("target"); > > NIT: `let`?
👍🏻
>> LayoutTests/resources/ui-helper.js:135 >> + const y = element.offsetTop + element.offsetHeight / 2; > > NIT: I'd add parenthesis around the `/ 2` to avoid ambiguity/complexity while reading
👍🏻
>> LayoutTests/resources/ui-helper.js:1103 >> + new Promise(resolve => target.addEventListener(eventName, e => { > > NIT: for readability, I usually avoid using inlined arrow functions unless I am intentionally using the implicit return value > ``` > new Promise((eventListenerResolve) => { > target.addEventListener(eventName, (e) => { > event = e; > eventListenerResolve(); > }, {once: true}) > }), > ``` > > NIT: I'd also recommend using a different variable name other than `resolve` to avoid shadowing
Sounds good! Changed from inline => to => { … }, and also renamed the two inner `resolve`s to avoid shadowing.
Wenson Hsieh
Comment 4
2020-06-29 16:09:28 PDT
Created
attachment 403130
[details]
Patch for landing
EWS
Comment 5
2020-06-29 16:59:04 PDT
Committed
r263708
: <
https://trac.webkit.org/changeset/263708
> All reviewed patches have been landed. Closing bug and clearing flags on
attachment 403130
[details]
.
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug