Bug 213729 - REGRESSION(r263626): 2 imported/w3c/web-platform-tests/cors/ tests failing constantly
Summary: REGRESSION(r263626): 2 imported/w3c/web-platform-tests/cors/ tests failing co...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-29 07:33 PDT by Jacob Uphoff
Modified: 2020-06-29 10:52 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jacob Uphoff 2020-06-29 07:33:39 PDT
imported/w3c/web-platform-tests/cors/credentials-flag.htm
imported/w3c/web-platform-tests/cors/origin.htm

These tests became a constant failure after commit r263626 for Catalina and iOS 13. 

History:

https://results.webkit.org/?suite=layout-tests&test=imported%2Fw3c%2Fweb-platform-tests%2Fcors%2Fcredentials-flag.htm

Diff:

--- /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/cors/credentials-flag-expected.txt
+++ /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/cors/credentials-flag-actual.txt
@@ -14,6 +14,6 @@
 PASS Access-Control-Allow-Credentials: 0 should be disallowed (async) 
 PASS Access-Control-Allow-Credentials: ,true should be disallowed (async) 
 PASS Access-Control-Allow-Credentials: true, should be disallowed (async) 
-FAIL Access-Control-Allow-Credentials: true%0B should be disallowed (async) assert_unreached: onload Reached unreachable code
-FAIL Access-Control-Allow-Credentials: true%0C should be disallowed (async) assert_unreached: onload Reached unreachable code
+PASS Access-Control-Allow-Credentials: true%0B should be disallowed (async) 
+PASS Access-Control-Allow-Credentials: true%0C should be disallowed (async) 
 

--- /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/cors/origin-expected.txt
+++ /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/cors/origin-actual.txt
@@ -33,11 +33,11 @@
 PASS Disallow origin: ,* 
 PASS Disallow origin: *, 
 PASS Disallow origin: \0* 
-FAIL Disallow origin: * assert_throws_dom: send function "function () { client.send() }" did not throw
-FAIL Disallow origin: * assert_throws_dom: send function "function () { client.send() }" did not throw
+PASS Disallow origin: * 
+PASS Disallow origin: * 
 PASS Disallow origin: *\0 
-FAIL Disallow origin: * assert_throws_dom: send function "function () { client.send() }" did not throw
-FAIL Disallow origin: * assert_throws_dom: send function "function () { client.send() }" did not throw
+PASS Disallow origin: * 
+PASS Disallow origin: * 
 PASS Disallow origin: '*' 
 PASS Disallow origin: "*" 
 PASS Disallow origin: * *
Comment 1 Chris Dumez 2020-06-29 07:34:39 PDT
Looks like they need to be rebaselined.
Comment 2 Chris Dumez 2020-06-29 07:38:25 PDT
Committed r263661: <https://trac.webkit.org/changeset/263661>
Comment 3 Ryan Haddad 2020-06-29 10:52:10 PDT
(In reply to Chris Dumez from comment #2)
> Committed r263661: <https://trac.webkit.org/changeset/263661>
This caused failures on Mojave, so I added a baseline for that OS in https://trac.webkit.org/changeset/263667/webkit.