Bug 213118 - Add a quirk to allow starting AudioContext if document was interacted
Summary: Add a quirk to allow starting AudioContext if document was interacted
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-06-12 02:30 PDT by youenn fablet
Modified: 2020-06-15 02:19 PDT (History)
7 users (show)

See Also:


Attachments
Patch (3.40 KB, patch)
2020-06-12 02:39 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Patch for landing (3.40 KB, patch)
2020-06-15 01:30 PDT, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description youenn fablet 2020-06-12 02:30:58 PDT
Add a quirk to allow starting AudioContext if document was interacted
Comment 1 youenn fablet 2020-06-12 02:39:14 PDT
Created attachment 401715 [details]
Patch
Comment 2 Eric Carlson 2020-06-12 10:22:46 PDT
Comment on attachment 401715 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=401715&action=review

> Source/WebCore/Modules/webaudio/AudioContext.cpp:1089
> +static bool isDocumentAllowingAutoplayWebAudio(const Document& document)

Minor nit: "is ... allowing" isn't quite right. Maybe something like "documentAllowsWebAudioToAutoPlay", or "doesDocumentAllowWebAudioToAutoPlay"?
Comment 3 youenn fablet 2020-06-12 13:17:40 PDT
<rdar://problem/64147813>
Comment 4 youenn fablet 2020-06-15 01:30:09 PDT
Created attachment 401887 [details]
Patch for landing
Comment 5 EWS 2020-06-15 02:13:13 PDT
Committed r263025: <https://trac.webkit.org/changeset/263025>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 401887 [details].
Comment 6 youenn fablet 2020-06-15 02:19:30 PDT
(In reply to Eric Carlson from comment #2)
> Comment on attachment 401715 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=401715&action=review
> 
> > Source/WebCore/Modules/webaudio/AudioContext.cpp:1089
> > +static bool isDocumentAllowingAutoplayWebAudio(const Document& document)
> 
> Minor nit: "is ... allowing" isn't quite right. Maybe something like
> "documentAllowsWebAudioToAutoPlay", or "doesDocumentAllowWebAudioToAutoPlay"?

I chose shouldDocumentAllowWebAudioToAutoPlay