Bug 213111 - [LFC][TFC] Add support for min/max-width
Summary: [LFC][TFC] Add support for min/max-width
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: zalan
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-06-11 20:53 PDT by zalan
Modified: 2020-06-12 08:56 PDT (History)
5 users (show)

See Also:


Attachments
Patch (14.44 KB, patch)
2020-06-11 21:28 PDT, zalan
no flags Details | Formatted Diff | Diff
Patch (15.24 KB, patch)
2020-06-12 08:16 PDT, zalan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description zalan 2020-06-11 20:53:21 PDT
ssia
Comment 1 zalan 2020-06-11 21:28:04 PDT
Created attachment 401705 [details]
Patch
Comment 2 Antti Koivisto 2020-06-12 07:13:00 PDT
Comment on attachment 401705 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=401705&action=review

> Source/WebCore/layout/blockformatting/BlockFormattingContext.cpp:401
> +ContentWidthAndMargin BlockFormattingContext::computedWidthAndMargin(const FloatingContext& floatingContext, const Box& layoutBox, const ConstraintsPair& constraintsPair)

It is somewhat confusing to have both 'computeWidthAndMargin' and 'computedWidthAndMargin' functions.

Maybe this could be 'computeContentWidthAndMargin' based on the return type?
Comment 3 zalan 2020-06-12 07:20:04 PDT
(In reply to Antti Koivisto from comment #2)
> Comment on attachment 401705 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=401705&action=review
> 
> > Source/WebCore/layout/blockformatting/BlockFormattingContext.cpp:401
> > +ContentWidthAndMargin BlockFormattingContext::computedWidthAndMargin(const FloatingContext& floatingContext, const Box& layoutBox, const ConstraintsPair& constraintsPair)
> 
> It is somewhat confusing to have both 'computeWidthAndMargin' and
> 'computedWidthAndMargin' functions.
> 
> Maybe this could be 'computeContentWidthAndMargin' based on the return type?
Good point. I think what I am going to do is move this function to geometry() where all the other computed* functions are. That would be inline with the current naming logic: *FormattingContext has the "void compute*" functions and they call the corresponding "Type Geometry::computed*" functions.
Comment 4 zalan 2020-06-12 08:16:47 PDT
Created attachment 401728 [details]
Patch
Comment 5 EWS 2020-06-12 08:55:07 PDT
Committed r262951: <https://trac.webkit.org/changeset/262951>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 401728 [details].
Comment 6 Radar WebKit Bug Importer 2020-06-12 08:56:23 PDT
<rdar://problem/64298644>