Bug 212648 - Pass WebPageProxyIdentifier to PreconnectTask
Summary: Pass WebPageProxyIdentifier to PreconnectTask
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alex Christensen
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-06-02 11:06 PDT by Alex Christensen
Modified: 2020-06-03 08:38 PDT (History)
2 users (show)

See Also:


Attachments
Patch (7.48 KB, patch)
2020-06-02 11:07 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (7.67 KB, patch)
2020-06-02 11:24 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (7.69 KB, patch)
2020-06-02 17:56 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Christensen 2020-06-02 11:06:17 PDT
Pass WebPageProxyIdentifier to PreconnectTask
Comment 1 Alex Christensen 2020-06-02 11:07:59 PDT
Created attachment 400843 [details]
Patch
Comment 2 Chris Dumez 2020-06-02 11:16:52 PDT
Comment on attachment 400843 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=400843&action=review

> Source/WebKit/NetworkProcess/NetworkProcess.cpp:1410
> +    parameters.webPageProxyID = webPageProxyID;

It would be good to set loadParameters.webPageID too.
Comment 3 Alex Christensen 2020-06-02 11:24:24 PDT
Created attachment 400846 [details]
Patch
Comment 4 Chris Dumez 2020-06-02 11:25:08 PDT
Comment on attachment 400846 [details]
Patch

r=me
Comment 5 Chris Dumez 2020-06-02 11:25:45 PDT
Comment on attachment 400846 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=400846&action=review

> Source/WebKit/NetworkProcess/NetworkProcess.cpp:1400
> +void NetworkProcess::preconnectTo(PAL::SessionID sessionID, WebPageProxyIdentifier webPageProxyID, WebCore::PageIdentifier pageID, const URL& url, const String& userAgent, WebCore::StoredCredentialsPolicy storedCredentialsPolicy, Optional<NavigatingToAppBoundDomain> isNavigatingToAppBoundDomain)

I think we normally call this webPageID instead of pageID nowadays.
Comment 6 Alex Christensen 2020-06-02 17:56:10 PDT
Created attachment 400869 [details]
Patch
Comment 7 EWS 2020-06-03 08:37:54 PDT
Committed r262487: <https://trac.webkit.org/changeset/262487>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 400869 [details].
Comment 8 Radar WebKit Bug Importer 2020-06-03 08:38:16 PDT
<rdar://problem/63928386>