Bug 212264 - [css-flex] Allow indefinite size flex items to be definite wrt resolving percentages inside them
Summary: [css-flex] Allow indefinite size flex items to be definite wrt resolving perc...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Sergio Villar Senin
URL:
Keywords: InRadar, WPTImpact
: 198375 210477 (view as bug list)
Depends on: 210089
Blocks:
  Show dependency treegraph
 
Reported: 2020-05-22 08:35 PDT by Sergio Villar Senin
Modified: 2021-10-24 06:56 PDT (History)
17 users (show)

See Also:


Attachments
Patch (7.61 KB, patch)
2020-05-22 08:43 PDT, Sergio Villar Senin
no flags Details | Formatted Diff | Diff
Patch (7.61 KB, patch)
2020-05-22 08:44 PDT, Sergio Villar Senin
rego: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sergio Villar Senin 2020-05-22 08:35:07 PDT
[css-flex] Allow indefinite size flex items to be definite wrt resolving percentages inside them
Comment 1 Sergio Villar Senin 2020-05-22 08:43:12 PDT
Created attachment 400049 [details]
Patch
Comment 2 Sergio Villar Senin 2020-05-22 08:44:37 PDT
Created attachment 400050 [details]
Patch
Comment 3 Manuel Rego Casasnovas 2020-05-22 09:34:11 PDT
Comment on attachment 400050 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=400050&action=review

r=me, thanks for the patch.

> LayoutTests/css3/flexbox/definite-main-size.html:61
>    <div class="rect flex-none"></div>

Would be nice to move this test "definite-main-size.html" into WPT. It seems it doesn't have anything engine related.

Of course this could be done in a follow-up patch.
Comment 4 Sergio Villar Senin 2020-05-25 07:18:32 PDT
Committed r262124: <https://trac.webkit.org/changeset/262124>
Comment 5 Radar WebKit Bug Importer 2020-05-25 07:19:17 PDT
<rdar://problem/63597024>
Comment 6 Simon Fraser (smfr) 2020-06-11 20:29:40 PDT
This caused bug 213110.
Comment 7 Sergio Villar Senin 2020-06-14 22:57:02 PDT
Reverted r262124 for reason:

Twitter videos go blank after exiting fullscreen

Committed r263018: <https://trac.webkit.org/changeset/263018>
Comment 8 Sergio Villar Senin 2020-06-23 08:56:25 PDT
Committed r263399: <https://trac.webkit.org/changeset/263399>
Comment 9 zalan 2020-07-22 14:29:07 PDT
This seems to have regressed Youtube's video uploading page (see bug 214655)
Comment 10 Manuel Rego Casasnovas 2020-07-23 00:44:05 PDT
(In reply to zalan from comment #9)
> This seems to have regressed Youtube's video uploading page (see bug 214655)

Sergio is on holidays until the end of the month, it might be better to revert it until he has time to investigate the regression properly.
Comment 11 zalan 2020-07-23 05:10:45 PDT
(In reply to Manuel Rego Casasnovas from comment #10)
> (In reply to zalan from comment #9)
> > This seems to have regressed Youtube's video uploading page (see bug 214655)
> 
> Sergio is on holidays until the end of the month, it might be better to
> revert it until he has time to investigate the regression properly.
Ok, thanks! Will revert it for now.
Comment 12 zalan 2020-07-23 10:29:22 PDT
reverted in https://trac.webkit.org/changeset/264775/webkit
Comment 13 David Kilzer (:ddkilzer) 2020-07-23 10:40:40 PDT
(In reply to zalan from comment #12)
> reverted in https://trac.webkit.org/changeset/264775/webkit
Comment 14 Sam Sneddon [:gsnedders] 2020-08-25 20:55:20 PDT
*** Bug 210477 has been marked as a duplicate of this bug. ***
Comment 15 Sergio Villar Senin 2020-09-07 02:54:21 PDT
Committed r266696: <https://trac.webkit.org/changeset/266696>
Comment 16 Joonghun Park 2021-10-24 06:34:26 PDT
*** Bug 198375 has been marked as a duplicate of this bug. ***