Bug 212153 - REGRESSION (r261892) [ Mac Debug ] 4 API tests failing related to ResourceLoadStatistics
Summary: REGRESSION (r261892) [ Mac Debug ] 4 API tests failing related to ResourceLoa...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: katherine_cheney
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-05-20 10:11 PDT by Truitt Savell
Modified: 2020-05-20 11:37 PDT (History)
7 users (show)

See Also:


Attachments
Patch (1.99 KB, patch)
2020-05-20 10:42 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Truitt Savell 2020-05-20 10:11:39 PDT
after the changes in https://trac.webkit.org/changeset/261892/webkit

This test is failing:
TestWebKitAPI.ResourceLoadStatistics.MigrateDataFromMissingTopFrameUniqueRedirectSameSiteStrictTableSchema

and these are timing out:
TestWebKitAPI.ResourceLoadStatistics.NetworkProcessRestart
TestWebKitAPI.ResourceLoadStatistics.ShouldNotGrandfatherOnStartupDatabase
TestWebKitAPI.ResourceLoadStatistics.ShouldNotGrandfatherOnStartup

Result output:
https://build.webkit.org/builders/Apple-Catalina-Debug-WK2-Tests/builds/4380/steps/run-api-tests/logs/stdio
Comment 1 Radar WebKit Bug Importer 2020-05-20 10:12:06 PDT
<rdar://problem/63452541>
Comment 2 Truitt Savell 2020-05-20 10:17:49 PDT
It looks like this test is specifically broken on Mojave Debug:

TestWebKitAPI.ResourceLoadStatistics.NoMessagesWhenNotTesting

History:
https://results.webkit.org/?suite=api-tests&test=TestWebKitAPI.ResourceLoadStatistics.NoMessagesWhenNotTesting
Comment 3 katherine_cheney 2020-05-20 10:42:31 PDT
Created attachment 399851 [details]
Patch
Comment 4 katherine_cheney 2020-05-20 10:45:47 PDT
I got a little too excited when deleting reset() calls in https://trac.webkit.org/changeset/261892/webkit. In this case it is needed because this statement is initialized in this function and does not use SQLiteStatementAutoResetScope, so it must be reset between iterations of the loop.
Comment 5 EWS 2020-05-20 11:37:51 PDT
Committed r261935: <https://trac.webkit.org/changeset/261935>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 399851 [details].