Bug 211451 - Check for app-bound domains should confirm WKAppBoundDomains key exists when checking for default app-bound protocols.
Summary: Check for app-bound domains should confirm WKAppBoundDomains key exists when ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: katherine_cheney
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-05-05 09:13 PDT by katherine_cheney
Modified: 2020-05-05 11:57 PDT (History)
3 users (show)

See Also:


Attachments
Patch (3.18 KB, patch)
2020-05-05 10:11 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff
Patch for landing (3.19 KB, patch)
2020-05-05 11:20 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description katherine_cheney 2020-05-05 09:13:07 PDT
Currently, the app-bound domains check returns true for special protocols without checking for the WKAppBoundDomains key.
Comment 1 katherine_cheney 2020-05-05 10:11:25 PDT
Created attachment 398521 [details]
Patch
Comment 2 katherine_cheney 2020-05-05 10:11:58 PDT
<rdar://problem/62715316>
Comment 3 katherine_cheney 2020-05-05 10:23:24 PDT
I confirmed this fix works manually. I was unable to write a test case for the empty WKAppBoundDomains case because TestWebKitAPI has the key in its Info.plist for other tests.
Comment 4 Brent Fulgham 2020-05-05 11:06:07 PDT
Comment on attachment 398521 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=398521&action=review

Looks good. r=me.

> Source/WebKit/UIProcess/WebsiteData/Cocoa/WebsiteDataStoreCocoa.mm:465
> +        // Must check for both an empty app bound domains and an empty key before returning nullopt

"both an empty app bound domains ..." maybe add set? or array? -- the plural domains with the 'an' is throwing me off.
Comment 5 katherine_cheney 2020-05-05 11:20:17 PDT
Created attachment 398529 [details]
Patch for landing
Comment 6 EWS 2020-05-05 11:56:36 PDT
Committed r261187: <https://trac.webkit.org/changeset/261187>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 398529 [details].
Comment 7 Radar WebKit Bug Importer 2020-05-05 11:57:18 PDT
<rdar://problem/62897375>