RESOLVED FIXED 211213
Ensure Intl classes don't have naming conflicts with unified builds
https://bugs.webkit.org/show_bug.cgi?id=211213
Summary Ensure Intl classes don't have naming conflicts with unified builds
Ross Kirsling
Reported 2020-04-29 17:54:36 PDT
Ensure Intl classes don't have naming conflicts with unified builds
Attachments
Patch (21.26 KB, patch)
2020-04-29 18:07 PDT, Ross Kirsling
no flags
Patch for landing (21.29 KB, patch)
2020-04-29 19:35 PDT, Ross Kirsling
no flags
Ross Kirsling
Comment 1 2020-04-29 18:07:24 PDT
Yusuke Suzuki
Comment 2 2020-04-29 19:19:32 PDT
Comment on attachment 398012 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=398012&action=review r=me > Source/JavaScriptCore/runtime/IntlCollator.h:60 > + static Vector<String> sortLocaleData(const String&, size_t); > + static Vector<String> searchLocaleData(const String&, size_t); > + Let's put it behind private: if possible. > Source/JavaScriptCore/runtime/IntlDateTimeFormat.h:57 > + static Vector<String> localeData(const String&, size_t); Ditto. > Source/JavaScriptCore/runtime/IntlNumberFormat.h:58 > + static Vector<String> localeData(const String&, size_t); Ditto. > Source/JavaScriptCore/runtime/IntlPluralRules.h:56 > + static Vector<String> localeData(const String&, size_t); Ditto. > Source/JavaScriptCore/runtime/IntlRelativeTimeFormat.h:55 > + static Vector<String> localeData(const String&, size_t); Ditto.
Ross Kirsling
Comment 3 2020-04-29 19:35:23 PDT
Created attachment 398021 [details] Patch for landing
EWS
Comment 4 2020-04-29 20:00:40 PDT
Committed r260931: <https://trac.webkit.org/changeset/260931> All reviewed patches have been landed. Closing bug and clearing flags on attachment 398021 [details].
Radar WebKit Bug Importer
Comment 5 2020-04-29 20:01:19 PDT
Darin Adler
Comment 6 2020-05-10 16:22:43 PDT
Comment on attachment 398021 [details] Patch for landing View in context: https://bugs.webkit.org/attachment.cgi?id=398021&action=review > Source/JavaScriptCore/runtime/IntlCollator.h:71 > + static Vector<String> sortLocaleData(const String&, size_t); > + static Vector<String> searchLocaleData(const String&, size_t); Avoiding name conflict is a good thing. Adding more in headers is not such a good thing. I guess I’m OK with this, but generally would be nice to have the headers be as small as possible and not have implementation details that they don’t need to.
Note You need to log in before you can comment on or make changes to this bug.