WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
211140
[JSC] Align upon the name isCallable instead of isFunction
https://bugs.webkit.org/show_bug.cgi?id=211140
Summary
[JSC] Align upon the name isCallable instead of isFunction
Ross Kirsling
Reported
2020-04-28 12:24:57 PDT
[JSC] Align upon the name isCallable instead of isFunction
Attachments
Patch
(48.78 KB, patch)
2020-04-28 12:28 PDT
,
Ross Kirsling
no flags
Details
Formatted Diff
Diff
Patch
(46.16 KB, patch)
2020-04-28 12:31 PDT
,
Ross Kirsling
no flags
Details
Formatted Diff
Diff
Patch for landing
(46.38 KB, patch)
2020-04-28 14:16 PDT
,
Ross Kirsling
no flags
Details
Formatted Diff
Diff
Show Obsolete
(2)
View All
Add attachment
proposed patch, testcase, etc.
Ross Kirsling
Comment 1
2020-04-28 12:28:07 PDT
Created
attachment 397868
[details]
Patch
Ross Kirsling
Comment 2
2020-04-28 12:31:39 PDT
Created
attachment 397870
[details]
Patch
Darin Adler
Comment 3
2020-04-28 12:33:38 PDT
Comment on
attachment 397870
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=397870&action=review
r=me assuming the EWS confirms this compiles everywhere
> Source/JavaScriptCore/runtime/JSCJSValueInlines.h:894 > if (!isCell()) > return false; > - return asCell()->isFunction(vm); > + return asCell()->isCallable(vm);
I really like && for functions like this: return isCell() && asCell()->isCallable(vm); Obviously that has nothing to do with this patch.
Ross Kirsling
Comment 4
2020-04-28 14:16:10 PDT
Created
attachment 397885
[details]
Patch for landing
EWS
Comment 5
2020-04-28 14:51:43 PDT
Committed
r260848
: <
https://trac.webkit.org/changeset/260848
> All reviewed patches have been landed. Closing bug and clearing flags on
attachment 397885
[details]
.
Radar WebKit Bug Importer
Comment 6
2020-04-28 14:52:17 PDT
<
rdar://problem/62548189
>
Saam Barati
Comment 7
2020-04-29 14:52:48 PDT
Comment on
attachment 397885
[details]
Patch for landing View in context:
https://bugs.webkit.org/attachment.cgi?id=397885&action=review
> Source/JavaScriptCore/ftl/FTLLowerDFGToB3.cpp:17902 > + LValue isCallable(LValue cell, SpeculatedType type = SpecFullTop)
This is wrong, this one really is "isFunction". You could rename this to "isJSFunction" or keep it as "isFunction"
Ross Kirsling
Comment 8
2020-04-29 15:16:45 PDT
Committed
r260919
: <
https://trac.webkit.org/changeset/260919
>
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug