[JSC] Clearly distinguish isConstructor from getConstructData
Created attachment 397629 [details]
I suppose with the usages clearly distinguished, Darin's suggestion of merging CallType/ConstructType into CallData/ConstructData would be a reasonable further improvement.
I can do this in a third patch if others like the idea too.
Created attachment 397630 [details]
Committed r260735: <https://trac.webkit.org/changeset/260735>
All reviewed patches have been landed. Closing bug and clearing flags on attachment 397630 [details].