RESOLVED FIXED 211026
Commit the scrolling tree from the main thread
https://bugs.webkit.org/show_bug.cgi?id=211026
Summary Commit the scrolling tree from the main thread
Simon Fraser (smfr)
Reported 2020-04-25 12:09:55 PDT
Commit the scrolling tree from the main thread
Attachments
Patch (14.19 KB, patch)
2020-04-25 12:13 PDT, Simon Fraser (smfr)
no flags
Patch (15.35 KB, patch)
2020-04-25 12:34 PDT, Simon Fraser (smfr)
darin: review+
Patch (9.94 KB, patch)
2020-04-25 13:25 PDT, Simon Fraser (smfr)
no flags
Patch (11.03 KB, patch)
2020-04-25 14:57 PDT, Simon Fraser (smfr)
no flags
Patch (11.07 KB, patch)
2020-04-25 15:19 PDT, Simon Fraser (smfr)
no flags
Simon Fraser (smfr)
Comment 1 2020-04-25 12:13:27 PDT
Radar WebKit Bug Importer
Comment 2 2020-04-25 12:14:10 PDT
Simon Fraser (smfr)
Comment 3 2020-04-25 12:34:03 PDT
Darin Adler
Comment 4 2020-04-25 13:05:41 PDT
Comment on attachment 397573 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=397573&action=review > Source/WebCore/page/scrolling/ScrollingCoordinator.h:71 > +using PlatformDisplayID = uint32_t; I think this name would work just as well without the word "platform" in it. > Source/WebCore/page/scrolling/ScrollingTree.h:57 > +#if ENABLE(SCROLLING_THREAD) > +using PlatformDisplayID = uint32_t; > +#endif Same comment as above that I don’t think the word "platform" is helpful in this name. Is there some way to avoid defining this type separately in multiple headers? Please add a blank line before this since it doesn’t fit great into the paragraph of forward-declared classes. > Source/WebCore/page/scrolling/mac/ScrollingCoordinatorMac.mm:108 > + auto stateTree = scrollingStateTree()->commit(LayerRepresentation::PlatformLayerRepresentation); > + scrollingTree()->commitTreeState(WTFMove(stateTree)); Would this read better as a single line? > Source/WebCore/page/scrolling/nicosia/ScrollingCoordinatorNicosia.cpp:98 > + auto stateTree = scrollingStateTree()->commit(LayerRepresentation::PlatformLayerRepresentation); > + scrollingTree()->commitTreeState(WTFMove(stateTree)); Would this read better as a single line?
Simon Fraser (smfr)
Comment 5 2020-04-25 13:22:01 PDT
Oops, I didn't mean to include the windowScreenDidChange changes in this page (webkit-patch upload strikes again)
Simon Fraser (smfr)
Comment 6 2020-04-25 13:25:07 PDT
Simon Fraser (smfr)
Comment 7 2020-04-25 14:57:30 PDT
Simon Fraser (smfr)
Comment 8 2020-04-25 15:19:09 PDT
EWS
Comment 9 2020-04-25 18:24:07 PDT
Committed r260716: <https://trac.webkit.org/changeset/260716> All reviewed patches have been landed. Closing bug and clearing flags on attachment 397591 [details].
Note You need to log in before you can comment on or make changes to this bug.