Bug 210742 - [CMake] gst-build-backed build fails
Summary: [CMake] gst-build-backed build fails
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Philippe Normand
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-04-20 05:24 PDT by Philippe Normand
Modified: 2020-04-21 01:42 PDT (History)
9 users (show)

See Also:


Attachments
Patch (2.21 KB, patch)
2020-04-20 05:27 PDT, Philippe Normand
no flags Details | Formatted Diff | Diff
Patch (2.77 KB, patch)
2020-04-20 09:09 PDT, Philippe Normand
calvaris: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Normand 2020-04-20 05:24:43 PDT
Because in gst-build the headers are stored in different subdirectories, it exposes an issue in the CMake build definitions.
Comment 1 Philippe Normand 2020-04-20 05:27:52 PDT
Created attachment 396967 [details]
Patch
Comment 2 Víctor M. Jáquez L. 2020-04-20 08:13:35 PDT
Oddly, this is also needed, only for WPE

diff --git a/Source/WebKit/PlatformWPE.cmake b/Source/WebKit/PlatformWPE.cmake
index 700ff0a480d..43e93e3b07f 100644
--- a/Source/WebKit/PlatformWPE.cmake
+++ b/Source/WebKit/PlatformWPE.cmake
@@ -279,6 +279,9 @@ list(APPEND WebKit_SYSTEM_INCLUDE_DIRECTORIES
     ${GIO_UNIX_INCLUDE_DIRS}
     ${GLIB_INCLUDE_DIRS}
     ${GSTREAMER_INCLUDE_DIRS}
+    ${GSTREAMER_AUDIO_INCLUDE_DIRS}
+    ${GSTREAMER_PBUTILS_INCLUDE_DIRS}
+    ${GSTREAMER_VIDEO_INCLUDE_DIRS}
     ${LIBSECCOMP_INCLUDE_DIRS}
     ${LIBSOUP_INCLUDE_DIRS}
 )
Comment 3 Philippe Normand 2020-04-20 09:01:27 PDT
Right:

In file included from ../../Source/WebKit/UIProcess/API/glib/WebKitWebView.cpp:36:
In file included from ../../Source/WebKit/UIProcess/API/glib/WebKitBackForwardListPrivate.h:28:
In file included from ../../Source/WebKit/UIProcess/WebBackForwardList.h:30:
In file included from ../../Source/WebKit/UIProcess/WebPageProxy.h:50:
In file included from ../../Source/WebKit/UIProcess/SuspendedPageProxy.h:32:
In file included from DerivedSources/WebKit/WebPageProxyMessagesReplies.h:27:
In file included from ../../Source/WebKit/Shared/WebPageCreationParameters.h:32:
In file included from ../../Source/WebKit/Shared/UserContentControllerParameters.h:29:
In file included from ../../Source/WebKit/Shared/WebCompiledContentRuleListData.h:31:
In file included from DerivedSources/ForwardingHeaders/WebCore/SharedBuffer.h:52:
In file included from DerivedSources/ForwardingHeaders/WebCore/GStreamerCommon.h:25:
DerivedSources/ForwardingHeaders/WebCore/GUniquePtrGStreamer.h:24:10: fatal error: 'gst/audio/audio.h' file not found
Comment 4 Philippe Normand 2020-04-20 09:03:52 PDT
(In reply to Víctor M. Jáquez L. from comment #2)
> Oddly, this is also needed, only for WPE
> 

The issue doesn't happen there for GTK because PlatformGTK.cmake pulls in pbutils, hence -base.
Comment 5 Philippe Normand 2020-04-20 09:09:38 PDT
Created attachment 396979 [details]
Patch
Comment 6 Charlie Turner 2020-04-20 09:38:58 PDT
Comment on attachment 396979 [details]
Patch

I don't understand why this has suddenly started breaking, but I can confirm it fixed my GTK build here as well (no flatpak here), so informal r+ from me.
Comment 7 Philippe Normand 2020-04-21 01:41:28 PDT
Committed r260419: <https://trac.webkit.org/changeset/260419>
Comment 8 Radar WebKit Bug Importer 2020-04-21 01:42:15 PDT
<rdar://problem/62096815>