Bug 210632 - [WebGL] Confirm there are no errors when setting up framebuffers
Summary: [WebGL] Confirm there are no errors when setting up framebuffers
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dean Jackson
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-04-16 19:42 PDT by Dean Jackson
Modified: 2020-04-17 16:31 PDT (History)
10 users (show)

See Also:


Attachments
Patch (5.69 KB, patch)
2020-04-17 15:56 PDT, Dean Jackson
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dean Jackson 2020-04-16 19:42:35 PDT
We're seeing crashes on macOS inside GraphicsContextGL::reshape(). Specifically when we submit work at the end of the function via glFlush.

At the moment the cause is a mystery, because we should bail out before then if the multisample renderbuffer was not complete. In the hope that it helps somewhat, add a call to glGetError to double check that there isn't anything horribly wrong before we talk to the GPU.
Comment 1 Radar WebKit Bug Importer 2020-04-16 19:42:48 PDT
<rdar://problem/61916680>
Comment 2 Dean Jackson 2020-04-17 15:56:06 PDT
Created attachment 396812 [details]
Patch
Comment 3 Dean Jackson 2020-04-17 16:31:18 PDT
Committed r260301: <https://trac.webkit.org/changeset/260301>