Bug 210566 - Switch NetworkProcess and NetworkProcessProxy messages to use CallbackID class
Summary: Switch NetworkProcess and NetworkProcessProxy messages to use CallbackID class
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: Safari 13
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Brent Fulgham
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-04-15 13:22 PDT by Brent Fulgham
Modified: 2020-04-16 17:53 PDT (History)
2 users (show)

See Also:


Attachments
Patch (15.81 KB, patch)
2020-04-15 13:29 PDT, Brent Fulgham
no flags Details | Formatted Diff | Diff
Patch for landing (16.11 KB, patch)
2020-04-16 17:27 PDT, Brent Fulgham
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brent Fulgham 2020-04-15 13:22:42 PDT
Instead of using the raw uint64_t type to represent callbacks, use the purpose built WebKit::CallbackID type.
Comment 1 Brent Fulgham 2020-04-15 13:24:11 PDT
<rdar://problem/61791784>
Comment 2 Brent Fulgham 2020-04-15 13:29:46 PDT
Created attachment 396567 [details]
Patch
Comment 3 David Kilzer (:ddkilzer) 2020-04-15 17:16:36 PDT
Comment on attachment 396567 [details]
Patch

r=me  (mac-wk2 is orange, so I didn't mark cq+)
Comment 4 Brent Fulgham 2020-04-16 12:08:09 PDT
It looks like Mac-wk2 is in some horrible state. Every patch I look at claims it is broken.
Comment 5 Brent Fulgham 2020-04-16 17:26:16 PDT
I confirmed that the test results are the same with or without the patch locally.
Comment 6 Brent Fulgham 2020-04-16 17:27:44 PDT
Created attachment 396727 [details]
Patch for landing
Comment 7 EWS 2020-04-16 17:53:12 PDT
Committed r260231: <https://trac.webkit.org/changeset/260231>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 396727 [details].