Bug 21049 - Opacity fails in multicolumn layouts
: Opacity fails in multicolumn layouts
Status: RESOLVED FIXED
: WebKit
CSS
: 528+ (Nightly build)
: Macintosh Mac OS X 10.5
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2008-09-24 01:17 PST by
Modified: 2010-05-19 16:02 PST (History)


Attachments
HTML markup demonstrating different behavior of opacity in second column (219 bytes, text/html)
2008-09-24 01:19 PST, Simon Raboczi
no flags Details
Screenshot of multi-col with Opacity:.8 links. (65.39 KB, image/jpeg)
2009-07-08 08:52 PST, jjm
no flags Details
Patch (95.95 KB, patch)
2010-05-18 23:23 PST, Dave Hyatt
no flags Review Patch | Details | Formatted Diff | Diff
Patch (97.29 KB, patch)
2010-05-19 00:15 PST, Dave Hyatt
oliver: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-09-24 01:17:23 PST
In all but the first column of a multicolumn layout, an opacity less than 1 is displayed as 0.  The following markup demonstrates this behavior:

<html>
<head>
<style>
body { -webkit-column-count: 2 }
div { height: 5000 }
span { opacity: 0.5 }
</style>
</head>
<body>
<div>Left <span>is dim.</span></div>
<div>Right <span>is invisible.</span></div>
</body>
</html>
------- Comment #1 From 2008-09-24 01:19:42 PST -------
Created an attachment (id=23741) [details]
HTML markup demonstrating different behavior of opacity in second column
------- Comment #2 From 2009-07-08 08:45:35 PST -------
*** Bug 27069 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2009-07-08 08:52:38 PST -------
Created an attachment (id=32454) [details]
Screenshot of multi-col with Opacity:.8 links.

Attached screenshot shows how webkit renders 1 column, then splits it up. Elements with opacity display as if they were in that one column.
------- Comment #4 From 2009-07-29 08:43:10 PST -------
*** Bug 27761 has been marked as a duplicate of this bug. ***
------- Comment #5 From 2010-05-14 20:21:45 PST -------
r59513 has made this better in that if the content is all contained in a single column it will behave correctly.  If it spans multiple columns, however, then it won't render correctly yet.
------- Comment #6 From 2010-05-18 23:10:29 PST -------
*** Bug 25455 has been marked as a duplicate of this bug. ***
------- Comment #7 From 2010-05-18 23:23:13 PST -------
Created an attachment (id=56462) [details]
Patch
------- Comment #8 From 2010-05-18 23:24:50 PST -------
Attachment 56462 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style', '--no-squash']" exit_code: 1
WebCore/rendering/RenderLayer.cpp:2549:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
WebCore/rendering/RenderLayer.cpp:2996:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Total errors found: 2 in 10 files


If any of these errors are false positives, please file a bug against check-webkit-style.
------- Comment #9 From 2010-05-19 00:15:22 PST -------
Created an attachment (id=56467) [details]
Patch
------- Comment #10 From 2010-05-19 13:09:03 PST -------
(From update of attachment 56467 [details])
r=me

I did like the factoring out of hit test and painting logic for the various renderer lists
------- Comment #11 From 2010-05-19 14:41:48 PST -------
Fixed.
------- Comment #12 From 2010-05-19 16:02:02 PST -------
http://trac.webkit.org/changeset/59784 might have broken GTK Linux 32-bit Debug
The following changes are on the blame list:
http://trac.webkit.org/changeset/59784
http://trac.webkit.org/changeset/59785
http://trac.webkit.org/changeset/59783