Bug 210178 - SameSite=None doesn't appear on attribute WebInspector
Summary: SameSite=None doesn't appear on attribute WebInspector
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: Safari 13
Hardware: Macintosh macOS 10.15
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-04-08 02:52 PDT by Toru Kobayashi
Modified: 2020-04-08 18:12 PDT (History)
3 users (show)

See Also:


Attachments
SameSite=None doesn't appear on the Network and Storage panel (406.65 KB, image/png)
2020-04-08 02:52 PDT, Toru Kobayashi
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toru Kobayashi 2020-04-08 02:52:17 PDT
Created attachment 395784 [details]
SameSite=None doesn't appear on the Network and Storage panel

# Steps to reproduce:

I've set cookies with SameSite=None(foo) and without the SameSite(foo2) attribute and then confirmed the results on the Network pane and Storage panel on the WebInspector.

- Access https://probable-oxidized-leather.glitch.me/
- Open Network panel
- See the cookie value for probable-oxidized-leather.glitch.me
- Open Storage panel
- See the cookie value for probable-oxidized-leather.glitch.me

# Actual results:

The cookie(foo2) value of the SameSite attribute is —.
See the attached file.

# Expected results:

The cookie(foo2) value of the SameSite should be "None".

The source code of the site is here.
https://glitch.com/edit/#!/probable-oxidized-leather

Safari Technology Preview(Release 103 (Safari 13.2, WebKit 15610.1.7.3.2)) is also the same behavior.
Comment 1 Radar WebKit Bug Importer 2020-04-08 16:52:26 PDT
<rdar://problem/61485555>
Comment 2 Devin Rousso 2020-04-08 17:27:45 PDT
The em dash (—) represents the "None" value, both in the case that it is explicitly specified (`SameSite=None`) and in the case that `SameSite` is entirely omitted (from what I understand, this will be interpreted as if `SameSite=None`).
Comment 3 Toru Kobayashi 2020-04-08 18:12:09 PDT
Thank you.

> The em dash (—) represents the "None" value

I understand the current behavior, but it seems to be a bit unclear.
Because it's not intuitive to identify `—` as `None`.
`—` is looks like an unset value rather than `None`.
I understand that Safari's default cookie value is `None`, but `None` is an explicit value, isn't it?
(Chrome will change the default value to `Lax`)

So I think it would be nice if WebInspector displays `None` for the value explicitly.