Bug 209442 - [ Mac wk1 Debug ] http/tests/css/shared-stylesheet-mutation-preconstruct.html is flaky failing.
Summary: [ Mac wk1 Debug ] http/tests/css/shared-stylesheet-mutation-preconstruct.html...
Status: RESOLVED DUPLICATE of bug 209072
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Macintosh macOS 10.14
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-03-23 15:40 PDT by Jason Lawrence
Modified: 2020-03-23 15:51 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Lawrence 2020-03-23 15:40:16 PDT
http/tests/css/shared-stylesheet-mutation-preconstruct.html

Description:
This test is flaky failing on Mac wk1 Debug. The failures have been occurring through most of the visible history.

History:
https://results.webkit.org/?suite=layout-tests&test=http%2Ftests%2Fcss%2Fshared-stylesheet-mutation-preconstruct.html&platform=mac&flavor=wk1&style=debug&limit=50000

Diff:
--- /Volumes/Data/slave/catalina-debug-tests-wk1/build/layout-test-results/http/tests/css/shared-stylesheet-mutation-preconstruct-expected.txt
+++ /Volumes/Data/slave/catalina-debug-tests-wk1/build/layout-test-results/http/tests/css/shared-stylesheet-mutation-preconstruct-actual.txt
@@ -175,7 +175,7 @@
 
 Test 12
 --------------------------------------
-PASS getComputedStyle(testElement, null).getPropertyValue('background-color') is 'rgb(0, 128, 0)'
+FAIL getComputedStyle(testElement, null).getPropertyValue('background-color') should be rgb(0, 128, 0). Was rgba(0, 0, 0, 0).
 
 @import url("data:text/css;charset=utf-8,%23testdiv%7Bbackground-color%3Agreen%20!important%7D");
 #testdiv { background-color: green; }
Comment 1 Radar WebKit Bug Importer 2020-03-23 15:40:35 PDT
<rdar://problem/60795743>
Comment 2 Jason Lawrence 2020-03-23 15:49:22 PDT
I have marked this test as failing while this issue is investigated.
https://trac.webkit.org/changeset/258881/webkit
Comment 3 Jason Lawrence 2020-03-23 15:51:54 PDT

*** This bug has been marked as a duplicate of bug 209072 ***