Bug 209283 - [ Mac wk2 ] tiled-drawing/scrolling/scroll-iframe-latched-selects.html is flaky failing.
Summary: [ Mac wk2 ] tiled-drawing/scrolling/scroll-iframe-latched-selects.html is fla...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Scrolling (show other bugs)
Version: WebKit Nightly Build
Hardware: Macintosh macOS 10.14
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-03-19 09:14 PDT by Jason Lawrence
Modified: 2020-03-24 09:51 PDT (History)
4 users (show)

See Also:


Attachments
Patch (2.41 KB, patch)
2020-03-23 20:38 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Lawrence 2020-03-19 09:14:11 PDT
tiled-drawing/scrolling/scroll-iframe-latched-selects.html

Description:
This test is flaky failing on Mac wk2. It looks like it was passing consistently until 3/18/2020. 

History:
https://results.webkit.org/?suite=layout-tests&test=tiled-drawing%2Fscrolling%2Fscroll-iframe-latched-selects.html&limit=50000

Diff:
--- /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/tiled-drawing/scrolling/scroll-iframe-latched-selects-expected.txt
+++ /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/tiled-drawing/scrolling/scroll-iframe-latched-selects-actual.txt
@@ -8,7 +8,7 @@
 
 PASS Leftmost <select> was scrolled
 PASS Leftmost <select> was not scrolled by the latch state logic
-PASS Rightmost <select> was properly scrolled.
+FAIL Rightmost <select> was not scrolled though it should.
 PASS successfullyParsed is true
 
 TEST COMPLETE
Comment 1 Radar WebKit Bug Importer 2020-03-19 09:26:31 PDT
<rdar://problem/60636466>
Comment 2 Jason Lawrence 2020-03-19 11:07:26 PDT
I have marked this test as failing while this issue is investigated.
https://trac.webkit.org/changeset/258716/webkit
Comment 3 Jason Lawrence 2020-03-19 11:11:24 PDT
I am able to reproduce this issue on r258694 and r258677 using the command below.
run-webkit-tests --iterations 1400 --exit-after-n-failures 3 -f --no-retry --clobber-old-results tiled-drawing/scrolling/scroll-iframe-latched-selects.html
Comment 4 Simon Fraser (smfr) 2020-03-21 11:54:01 PDT
Still flaky.
Comment 5 Simon Fraser (smfr) 2020-03-23 20:38:47 PDT
Created attachment 394345 [details]
Patch
Comment 6 Simon Fraser (smfr) 2020-03-23 20:41:23 PDT
https://trac.webkit.org/changeset/258903/webkit