NEW 209121
[JSC] Rename ArrayBuffer::slice to ArrayBuffer::trySlice and insert appropriate checks
https://bugs.webkit.org/show_bug.cgi?id=209121
Summary [JSC] Rename ArrayBuffer::slice to ArrayBuffer::trySlice and insert appropria...
Yusuke Suzuki
Reported 2020-03-15 04:27:44 PDT
[JSC] Rename ArrayBuffer::slice to ArrayBuffer::trySlice and insert appropriate checks
Attachments
Patch (13.31 KB, patch)
2020-03-15 04:28 PDT, Yusuke Suzuki
mark.lam: review+
Yusuke Suzuki
Comment 1 2020-03-15 04:28:50 PDT
Mark Lam
Comment 2 2020-03-15 12:21:08 PDT
Comment on attachment 393614 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=393614&action=review r=me with fix. > Source/WebCore/bindings/js/StructuredClone.cpp:62 > + return JSValue::encode(JSC::throwOutOfMemoryError(globalObject, scope)); /globalObject/lexicalGlobalObject/ > Source/WebCore/bindings/js/StructuredClone.cpp:63 > + return JSValue::encode(JSArrayBuffer::create(lexicalGlobalObject->vm(), lexicalGlobalObject->arrayBufferStructure(ArrayBufferSharingMode::Default), WTFMove(slicedBuffer))); Not due to your change, but can you jut use vm here instead of lexicalGlobalObject->vm()? We've already pre-computed it above.
Note You need to log in before you can comment on or make changes to this bug.