Bug 209104 - [GTK] Add gtk-wk2 to EWS bubbles
Summary: [GTK] Add gtk-wk2 to EWS bubbles
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Diego Pino
URL:
Keywords: InRadar
: 234270 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-03-13 23:19 PDT by Diego Pino
Modified: 2021-12-16 07:19 PST (History)
8 users (show)

See Also:


Attachments
Patch (1.83 KB, patch)
2020-03-13 23:20 PDT, Diego Pino
no flags Details | Formatted Diff | Diff
Patch (2.15 KB, patch)
2020-08-26 04:40 PDT, Diego Pino
no flags Details | Formatted Diff | Diff
Patch (2.22 KB, patch)
2021-12-15 19:51 PST, Carlos Alberto Lopez Perez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Pino 2020-03-13 23:19:46 PDT
[GTK] Add gtk-wk2 to EWS bubbles
Comment 1 Diego Pino 2020-03-13 23:20:28 PDT
Created attachment 393577 [details]
Patch
Comment 2 Diego Pino 2020-08-26 04:40:29 PDT
Created attachment 407290 [details]
Patch
Comment 3 Aakash Jain 2020-08-28 10:24:01 PDT
Comment on attachment 407290 [details]
Patch

r- since the test don't seems to be in good enough shape to be enabled here (as per the data from uat instance). Many tests are flaky/failing.

Also, r265212 would need to be reverted as well in order to enable this queue.
Comment 4 Carlos Alberto Lopez Perez 2021-12-15 19:50:08 PST
On bug 231999 a new class has been added for running GTK layout tests on the EWS which can cope with a tree that is not green or that has random flakies.

This has been working for several weeks and it seems to be working well. It is still a bit slow but that will improve after bug 234378 and also after I connect a few more powerful workers that I still couldn't connect (igalia10, igalia12 and igalia13). I plan to do that in the next few days.

I think is time to add the bubble now.

I will upload a new patch.
Comment 5 Carlos Alberto Lopez Perez 2021-12-15 19:51:45 PST
Created attachment 447319 [details]
Patch
Comment 6 Carlos Alberto Lopez Perez 2021-12-15 19:53:55 PST
*** Bug 234270 has been marked as a duplicate of this bug. ***
Comment 7 EWS 2021-12-16 07:18:13 PST
Committed r287134 (245318@main): <https://commits.webkit.org/245318@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 447319 [details].
Comment 8 Radar WebKit Bug Importer 2021-12-16 07:19:20 PST
<rdar://problem/86574934>