Bug 20901 - Banking Website redirects to start page
Summary: Banking Website redirects to start page
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: https://www.dresdner-privat.de/
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-17 12:46 PDT by gauchi
Modified: 2008-12-29 00:47 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gauchi 2008-09-17 12:46:48 PDT
The problem is reproducible with WebKit, it does not appear with Safari (3.1.2)

How to reproduce:

go to dresdner-privat.de

Click on login on top right
On the right of the credentials boxes, there is a link "OnlineBanking testen"
Click on "Kontenübersicht" below the large "Testen Sie jetzt"

after some waiting page, a list of bank accounts is displayed. At least when using Safari. With the Nightly Webkit build, You are redirected to the start page, although you are marked as logged in
Comment 1 Alexey Proskuryakov 2008-09-18 02:10:09 PDT
I couldn't reproduce this with a local build of r36292 on Mac OS X 10.5.5 (tried twice).
Comment 2 gauchi 2008-09-18 02:18:11 PDT
(In reply to comment #1)
> I couldn't reproduce this with a local build of r36292 on Mac OS X 10.5.5
> (tried twice).
> 

I get it with r36519 (nightly build). I'll try a binary search when I find the time.
Comment 3 gauchi 2008-10-03 14:20:10 PDT
I found that the problem exists since revision 36244, svn log says this is the merge of squirrelfish extreme. Is it possible to switch off automatic redirects for debugging (or see the raw http - this page is encrypted, so using wireshark should not be an option)
Comment 4 Robert Blaut 2008-12-28 11:37:23 PST
I cannot reproduce the problem in WebKit r39474. Gauchi, is it still replicable to you?
Comment 5 gauchi 2008-12-29 00:47:19 PST
no, it seems the problem is fixed, thank you