Bug 208972 - REGRESSION (r254054): finance.google.com watch list renders initially then disappears for 5+ seconds before reappearing
Summary: REGRESSION (r254054): finance.google.com watch list renders initially then di...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-03-11 20:21 PDT by Simon Fraser (smfr)
Modified: 2020-03-12 10:15 PDT (History)
10 users (show)

See Also:


Attachments
Patch (7.85 KB, patch)
2020-03-11 20:29 PDT, Simon Fraser (smfr)
zalan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2020-03-11 20:21:44 PDT
REGRESSION (r254054): finance.google.com watch list renders initially then disappears for 5+ seconds before reappearing
Comment 1 Simon Fraser (smfr) 2020-03-11 20:29:09 PDT
Created attachment 393333 [details]
Patch
Comment 2 zalan 2020-03-11 20:33:50 PDT
Comment on attachment 393333 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=393333&action=review

> Source/WebCore/rendering/style/RenderStyle.cpp:822
> +        if (m_boxData->hasAutoUsedZIndex() != other.m_boxData->hasAutoUsedZIndex())
> +            return true;

It's a bit odd though that z-index change needs layout (and visual overflow computation as well. LFC should be better at this.)
Comment 3 Maciej Stachowiak 2020-03-11 22:17:02 PDT
Are the bot failures real?
Comment 4 Maciej Stachowiak 2020-03-11 22:18:18 PDT
WK1 and WK2 both showing css3/blending/repaint/blend-mode-isolate-stacking-context.html as failing, sounds possibly caused by this bug.
Comment 5 Simon Fraser (smfr) 2020-03-11 22:54:49 PDT
(In reply to Maciej Stachowiak from comment #4)
> WK1 and WK2 both showing
> css3/blending/repaint/blend-mode-isolate-stacking-context.html as failing,
> sounds possibly caused by this bug.

Changes in the order of repaints, which is not surprising. I'll verify that the rendering is correct, and rebaseline.
Comment 6 Antoine Quint 2020-03-12 01:01:27 PDT
<rdar://problem/59727171>
Comment 7 Simon Fraser (smfr) 2020-03-12 10:15:55 PDT
https://trac.webkit.org/changeset/258336/webkit