Bug 208890 - [ macOS iOS ] imported/w3c/web-platform-tests/IndexedDB/idbobjectstore_openKeyCursor.htm is flaky failing
Summary: [ macOS iOS ] imported/w3c/web-platform-tests/IndexedDB/idbobjectstore_openKe...
Status: RESOLVED DUPLICATE of bug 228241
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-03-10 15:46 PDT by Jacob Uphoff
Modified: 2021-07-30 10:18 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jacob Uphoff 2020-03-10 15:46:06 PDT
imported/w3c/web-platform-tests/IndexedDB/idbobjectstore_openKeyCursor.htm

This test has been a flaky failure for all visible history for the test on macOS and iOS. For macOS it seems to be failing for wk1 only and for iOS it seems to be failing for wk2.

History:

https://results.webkit.org/?suite=layout-tests&test=imported%2Fw3c%2Fweb-platform-tests%2FIndexedDB%2Fidbobjectstore_openKeyCursor.htm

Diff:

--- /Volumes/Data/slave/ios-simulator-13-release-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/IndexedDB/idbobjectstore_openKeyCursor-expected.txt
+++ /Volumes/Data/slave/ios-simulator-13-release-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/IndexedDB/idbobjectstore_openKeyCursor-actual.txt
@@ -1,7 +1,9 @@
+
+Harness Error (TIMEOUT), message = null
 
 PASS IDBObjectStore.openKeyCursor() - forward iteration 
 PASS IDBObjectStore.openKeyCursor() - reverse iteration 
 PASS IDBObjectStore.openKeyCursor() - forward iteration with range 
-PASS IDBObjectStore.openKeyCursor() - reverse iteration with range 
+TIMEOUT IDBObjectStore.openKeyCursor() - reverse iteration with range Test timed out
 PASS IDBObjectStore.openKeyCursor() - invalid inputs
Comment 1 Radar WebKit Bug Importer 2020-03-10 15:47:54 PDT
<rdar://problem/60295126>
Comment 2 Jacob Uphoff 2020-03-10 15:55:33 PDT
Set expectations here: https://trac.webkit.org/changeset/258236/webkit
Comment 3 Sihui Liu 2021-07-30 10:18:48 PDT
Expectations updated at https://bugs.webkit.org/show_bug.cgi?id=228241 as the test is no longer flaky.

*** This bug has been marked as a duplicate of bug 228241 ***