Bug 208817 - [ iOS and Mac Debug ] fast/canvas/webgl/simulated-vertexAttrib0-invalid-indicies.html is flaky timing out and crashing.
Summary: [ iOS and Mac Debug ] fast/canvas/webgl/simulated-vertexAttrib0-invalid-indic...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks: 208724
  Show dependency treegraph
 
Reported: 2020-03-09 08:57 PDT by Jason Lawrence
Modified: 2020-03-23 15:53 PDT (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Lawrence 2020-03-09 08:57:01 PDT
fast/canvas/webgl/simulated-vertexAttrib0-invalid-indicies.html

Description:
This test is flaky timing out and crashing on iOS and Mac. It appears to have a regression point of r258025. I was not able to find a valid crash log or diff.

History:
https://results.webkit.org/?suite=layout-tests&test=fast%2Fcanvas%2Fwebgl%2Fsimulated-vertexAttrib0-invalid-indicies.html

Diff/Crash log:
No crash log found for WebKitTestRunner:96552.

stdout:
Content-Type: text/plain
CONSOLE MESSAGE: line 49: WebGL: INVALID_OPERATION: drawElements: attempt to access out of bounds arrays
PASS: MAX_UINT index was unable to be simulated
PASS: MAX_UINT index did not crash
FAIL: Huge index did not fail validation
PASS: Huge index did not crash

#EOF
#EOF

stderr:
#EOF
Unable to shrink memory footprint of process (5839 MB) below the kill thresold (4096 MB). Killed
#CRASHED - com.apple.WebKit.WebContent.Development (pid 97161)
LEAK: 1 WebProcessPool
LEAK: 1 WebPageProxy
Comment 1 Radar WebKit Bug Importer 2020-03-09 09:10:53 PDT
<rdar://problem/60225353>
Comment 2 Jason Lawrence 2020-03-09 09:23:48 PDT
I have marked this test as passing while this issue is investigated.
https://trac.webkit.org/changeset/258145/webkit
Comment 3 Jason Lawrence 2020-03-09 09:30:53 PDT
I can reproduce the issue with r258141 and r258024 using the command below.

run-webkit-tests --iterations 1000 --exit-after-n-failures 3 --debug --force-f fast/canvas/webgl/simulated-vertexAttrib0-invalid-indicies.html

[6/1000] fast/canvas/webgl/simulated-vertexAttrib0-invalid-indicies.html failed unexpectedly (test timed out, test was not run)
[7/1000] fast/canvas/webgl/simulated-vertexAttrib0-invalid-indicies.html failed unexpectedly (test timed out, test was not run)
[8/1000] fast/canvas/webgl/simulated-vertexAttrib0-invalid-indicies.html failed unexpectedly (test timed out, test was not run)
Exiting early after 3 failures. 3 tests run.


0 tests ran as expected, 3 didn't (997 didn't run):
Comment 4 Alexey Proskuryakov 2020-03-09 17:40:46 PDT
Please revert r258025 (and unskip the test).
Comment 5 Kenneth Russell 2020-03-10 10:19:35 PDT
@ap could we please hold off for a couple more hours? It looks like there is some old code in WebKit for vertex attribute 0 simulation that is causing this flaky crash, and that it should be #ifdef'd out with USE_ANGLE.
Comment 6 Dean Jackson 2020-03-10 13:11:52 PDT
I've temporarily reverted 258025. I have a WIP fix for not-simulating vertex attribute 0. I'll turn them both on in the same patch.
Comment 7 Dean Jackson 2020-03-10 13:12:17 PDT
"Fixed" in r258226
Comment 8 Kenneth Russell 2020-03-16 13:13:59 PDT
Linking to the related bug for tracking purposes.