Bug 208374 - [GTK][WPE] Stop using mediaControlsBase.js
Summary: [GTK][WPE] Stop using mediaControlsBase.js
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2020-02-28 07:16 PST by Carlos Garcia Campos
Modified: 2020-03-02 02:27 PST (History)
15 users (show)

See Also:


Attachments
Patch (46.69 KB, patch)
2020-02-28 07:17 PST, Carlos Garcia Campos
calvaris: review+
Details | Formatted Diff | Diff
Patch (46.12 KB, patch)
2020-02-28 07:27 PST, Carlos Garcia Campos
calvaris: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2020-02-28 07:16:04 PST
Move the required base functionality to mediaControlsAdwaita.js and use that single file.
Comment 1 Carlos Garcia Campos 2020-02-28 07:17:58 PST
Created attachment 391976 [details]
Patch
Comment 2 Carlos Garcia Campos 2020-02-28 07:27:02 PST
Created attachment 391977 [details]
Patch
Comment 3 Xabier Rodríguez Calvar 2020-02-28 07:55:29 PST
Comment on attachment 391976 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=391976&action=review

Nit: things are ok as they are now but if you feel like giving it another shot, I would try to use let and const instead of var. Obviously let for things that are going to change and const for those that are not. Your call.

> Source/WebCore/Modules/mediacontrols/mediaControlsAdwaita.js:336
> +        this.controls.panel.classList.add(this.ClassNames.show);
> +        this.controls.panel.classList.remove(this.ClassNames.hidden);

Nit: I think it makes more sense to switch these lines to remove the hidden first and then add the show.
Comment 4 Carlos Garcia Campos 2020-03-02 02:25:39 PST
(In reply to Xabier Rodríguez Calvar from comment #3)
> Comment on attachment 391976 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=391976&action=review
> 
> Nit: things are ok as they are now but if you feel like giving it another
> shot, I would try to use let and const instead of var. Obviously let for
> things that are going to change and const for those that are not. Your call.

I don't know JavaScript, but if it's a mechanical change I can give it a try in a follow up patch if you think it's an important change.

> > Source/WebCore/Modules/mediacontrols/mediaControlsAdwaita.js:336
> > +        this.controls.panel.classList.add(this.ClassNames.show);
> > +        this.controls.panel.classList.remove(this.ClassNames.hidden);
> 
> Nit: I think it makes more sense to switch these lines to remove the hidden
> first and then add the show.

Ok.
Comment 5 Carlos Garcia Campos 2020-03-02 02:27:50 PST
Committed r257705: <https://trac.webkit.org/changeset/257705>