Bug 208196 - [JSC][MIPS] Adding support to Checkpoints
Summary: [JSC][MIPS] Adding support to Checkpoints
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Caio Lima
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-02-25 07:40 PST by Caio Lima
Modified: 2020-02-26 06:07 PST (History)
10 users (show)

See Also:


Attachments
Patch (6.22 KB, patch)
2020-02-25 08:23 PST, Caio Lima
no flags Details | Formatted Diff | Diff
Patch (6.42 KB, patch)
2020-02-26 05:09 PST, Caio Lima
no flags Details | Formatted Diff | Diff
Patch (6.41 KB, patch)
2020-02-26 05:16 PST, Caio Lima
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Caio Lima 2020-02-25 07:40:46 PST
...
Comment 1 Caio Lima 2020-02-25 08:23:11 PST
Created attachment 391653 [details]
Patch
Comment 2 Yusuke Suzuki 2020-02-25 13:07:24 PST
Comment on attachment 391653 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=391653&action=review

r=me

> Source/JavaScriptCore/offlineasm/mips.rb:688
> +            if node.name =~ /^.*_return_location(?:_(?:wide16|wide32))?$/ or node.name.start_with?("_checkpoint_osr_exit_from_inlined_call_trampoline")

This sounds like, we should rename _checkpoint_osr_exit_from_inlined_call_trampoline to _checkpoint_osr_exit_from_inlined_call_trampoline_return_location, because it is return-location.
Can you file a FIXME here?
Comment 3 Caio Lima 2020-02-26 05:09:10 PST
Created attachment 391738 [details]
Patch
Comment 4 Caio Lima 2020-02-26 05:16:12 PST
Created attachment 391739 [details]
Patch
Comment 5 Caio Lima 2020-02-26 05:20:03 PST
(In reply to Yusuke Suzuki from comment #2)
> Comment on attachment 391653 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=391653&action=review
> 
> r=me

Thank you very much for the review!

> > Source/JavaScriptCore/offlineasm/mips.rb:688
> > +            if node.name =~ /^.*_return_location(?:_(?:wide16|wide32))?$/ or node.name.start_with?("_checkpoint_osr_exit_from_inlined_call_trampoline")
> 
> This sounds like, we should rename
> _checkpoint_osr_exit_from_inlined_call_trampoline to
> _checkpoint_osr_exit_from_inlined_call_trampoline_return_location, because
> it is return-location.
> Can you file a FIXME here?

Done. I created https://bugs.webkit.org/show_bug.cgi?id=208236 and I'm going to upload a patch soon.
Comment 6 WebKit Commit Bot 2020-02-26 06:06:36 PST
Comment on attachment 391739 [details]
Patch

Clearing flags on attachment: 391739

Committed r257466: <https://trac.webkit.org/changeset/257466>
Comment 7 WebKit Commit Bot 2020-02-26 06:06:38 PST
All reviewed patches have been landed.  Closing bug.
Comment 8 Radar WebKit Bug Importer 2020-02-26 06:07:19 PST
<rdar://problem/59803601>