WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
207966
[First paint] Introduce FrameView::m_firstVisuallyNonEmptyLayoutMilestoneIsPending
https://bugs.webkit.org/show_bug.cgi?id=207966
Summary
[First paint] Introduce FrameView::m_firstVisuallyNonEmptyLayoutMilestoneIsPe...
zalan
Reported
2020-02-19 14:38:33 PST
to indicate that we've got a pending callback and we have to issue this callback soon after the content turns into visually non-empty.
Attachments
Patch
(4.26 KB, patch)
2020-02-19 14:43 PST
,
zalan
no flags
Details
Formatted Diff
Diff
Patch
(4.25 KB, patch)
2020-02-19 15:59 PST
,
zalan
no flags
Details
Formatted Diff
Diff
Show Obsolete
(1)
View All
Add attachment
proposed patch, testcase, etc.
Radar WebKit Bug Importer
Comment 1
2020-02-19 14:38:51 PST
<
rdar://problem/59606528
>
zalan
Comment 2
2020-02-19 14:43:49 PST
Created
attachment 391203
[details]
Patch
Simon Fraser (smfr)
Comment 3
2020-02-19 15:10:11 PST
Comment on
attachment 391203
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=391203&action=review
> Source/WebCore/page/FrameView.cpp:5144 > + addPaintPendingMilestones(DidFirstMeaningfulPaint);
I"m sad that we're giving up on the distinction between "first contentful paint" and "first meaningful paint". How does "relevant repainted objects" threshold fit into this?
> Source/WebCore/page/FrameView.h:924 > + bool m_contentIsQualifiedAsVisuallyNonEmpty { false }; > + bool m_firstVisuallyNonEmptyLayoutCallbackPending { true };
Maybe collapse these two into a "state" enum. If not, please be consistent with naming. Maybe "contentIsQualified" -> qualifiesAs, and m_firstVisuallyNonEmptyLayoutCallbackPending -> m_didFirstMeaningfulPaintMilestone pending
zalan
Comment 4
2020-02-19 15:57:13 PST
(In reply to Simon Fraser (smfr) from
comment #3
)
> Comment on
attachment 391203
[details]
> Patch > > View in context: >
https://bugs.webkit.org/attachment.cgi?id=391203&action=review
> > > Source/WebCore/page/FrameView.cpp:5144 > > + addPaintPendingMilestones(DidFirstMeaningfulPaint); > > I"m sad that we're giving up on the distinction between "first contentful > paint" and "first meaningful paint". How does "relevant repainted objects" > threshold fit into this?
I think it's more accurate to say that we don't even have the clear distinction yet.
> > > Source/WebCore/page/FrameView.h:924 > > + bool m_contentIsQualifiedAsVisuallyNonEmpty { false }; > > + bool m_firstVisuallyNonEmptyLayoutCallbackPending { true }; > > Maybe collapse these two into a "state" enum. > > If not, please be consistent with naming. Maybe "contentIsQualified" -> > qualifiesAs, and m_firstVisuallyNonEmptyLayoutCallbackPending -> > m_didFirstMeaningfulPaintMilestone pending
I'll do that.
zalan
Comment 5
2020-02-19 15:59:22 PST
Created
attachment 391213
[details]
Patch
WebKit Commit Bot
Comment 6
2020-02-19 16:48:13 PST
Comment on
attachment 391213
[details]
Patch Clearing flags on attachment: 391213 Committed
r256999
: <
https://trac.webkit.org/changeset/256999
>
WebKit Commit Bot
Comment 7
2020-02-19 16:48:15 PST
All reviewed patches have been landed. Closing bug.
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug