Bug 207848 - [ Mac wk2 Release ] fast/scrolling/latching/scroll-iframe-fragment.html is flaky failing.
Summary: [ Mac wk2 Release ] fast/scrolling/latching/scroll-iframe-fragment.html is fl...
Status: RESOLVED DUPLICATE of bug 197819
Alias: None
Product: WebKit
Classification: Unclassified
Component: Scrolling (show other bugs)
Version: WebKit Nightly Build
Hardware: Mac macOS 10.15
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-02-17 11:00 PST by Jason Lawrence
Modified: 2020-03-21 11:57 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Lawrence 2020-02-17 11:00:11 PST
fast/scrolling/latching/scroll-iframe-fragment.html

Description:
This test is flaky failing throughout the visible history. The oldest failure with a diff that I'm able to locate is r254332.

History:
https://results.webkit.org/?suite=layout-tests&test=fast%2Fscrolling%2Flatching%2Fscroll-iframe-fragment.html&flavor=wk2&style=release

Diff:
--- /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/fast/scrolling/latching/scroll-iframe-fragment-expected.txt
+++ /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/fast/scrolling/latching/scroll-iframe-fragment-actual.txt
@@ -9,5 +9,5 @@
 TEST COMPLETE
 IFrame display height = 500
 Mouse moved to (28, 466)
-PASS IFrame received wheel events.
+FAIL IFrame did not receive wheel events.
Comment 1 Radar WebKit Bug Importer 2020-02-17 11:00:36 PST
<rdar://problem/59517639>
Comment 2 Jason Lawrence 2020-02-17 12:00:39 PST
I have marked this test as failing while this issue is investigated.
https://trac.webkit.org/changeset/256757/webkit
Comment 3 Simon Fraser (smfr) 2020-03-21 11:57:47 PDT
No longer flakey. Expectation removed in r258701.

*** This bug has been marked as a duplicate of bug 197819 ***