Bug 207653 - REGRESSION: (256381) [ macOS ] http/tests/workers/service/serviceworkerclients-claim.https.html is flaky failing
Summary: REGRESSION: (256381) [ macOS ] http/tests/workers/service/serviceworkerclient...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Service Workers (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-02-12 12:08 PST by Jacob Uphoff
Modified: 2020-02-13 13:42 PST (History)
6 users (show)

See Also:


Attachments
Patch (3.18 KB, patch)
2020-02-12 12:25 PST, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jacob Uphoff 2020-02-12 12:08:57 PST
http/tests/workers/service/serviceworkerclients-claim.https.html

This started after commit 256381

History:

https://results.webkit.org/?suite=layout-tests&test=http%2Ftests%2Fworkers%2Fservice%2Fserviceworkerclients-claim.https.html&limit=50000

Diff:

--- /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/http/tests/workers/service/serviceworkerclients-claim.https-expected.txt
+++ /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/http/tests/workers/service/serviceworkerclients-claim.https-actual.txt
@@ -1,6 +1,3 @@
-CONSOLE MESSAGE: Origin null is not allowed by Access-Control-Allow-Origin.
-CONSOLE MESSAGE: Fetch API cannot load https://127.0.0.1:8443/pinkelephant due to access control checks.
-CONSOLE MESSAGE: line 1: Unhandled Promise Rejection: TypeError: Origin null is not allowed by Access-Control-Allow-Origin.
 
 
 PASS Setup worker
Comment 1 Radar WebKit Bug Importer 2020-02-12 12:09:15 PST
<rdar://problem/59396225>
Comment 2 youenn fablet 2020-02-12 12:25:02 PST
Created attachment 390545 [details]
Patch
Comment 3 youenn fablet 2020-02-13 12:15:05 PST
Ping review?
Comment 4 WebKit Commit Bot 2020-02-13 13:42:02 PST
Comment on attachment 390545 [details]
Patch

Clearing flags on attachment: 390545

Committed r256537: <https://trac.webkit.org/changeset/256537>
Comment 5 WebKit Commit Bot 2020-02-13 13:42:03 PST
All reviewed patches have been landed.  Closing bug.