Bug 207577 - [ Mac wk2 ] http/tests/ssl/applepay/ApplePayBillingAddress.html a flaky failure
Summary: [ Mac wk2 ] http/tests/ssl/applepay/ApplePayBillingAddress.html a flaky failure
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Macintosh Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-02-11 13:00 PST by Jason Lawrence
Modified: 2020-02-12 10:57 PST (History)
6 users (show)

See Also:


Attachments
Patch (1.49 KB, patch)
2020-02-11 16:49 PST, Nikos Mouchtaris
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Lawrence 2020-02-11 13:00:12 PST
http/tests/ssl/applepay/ApplePayBillingAddress.html

Description:
This test is flaky failing on Mac wk2.

History:
https://results.webkit.org/?suite=layout-tests&test=http%2Ftests%2Fssl%2Fapplepay%2FApplePayBillingAddress.html

Diff:
--- /Volumes/Data/slave/mojave-debug-tests-wk2/build/layout-test-results/http/tests/ssl/applepay/ApplePayBillingAddress-expected.txt
+++ /Volumes/Data/slave/mojave-debug-tests-wk2/build/layout-test-results/http/tests/ssl/applepay/ApplePayBillingAddress-actual.txt
@@ -1,3 +1,4 @@
+CONSOLE MESSAGE: Unhandled Promise Rejection: AbortError: The operation was aborted.
 Test that billingAddress member of ApplePayPaymentMethod is populated in paymentmethodchange callback
 
 On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
Comment 1 Radar WebKit Bug Importer 2020-02-11 13:00:33 PST
<rdar://problem/59360124>
Comment 2 Jason Lawrence 2020-02-11 13:12:23 PST
I have marked this test as failing while this issue is investigated.
https://trac.webkit.org/changeset/256344/webkit

Also, I am not able to reproduce this issue on r256238 using this command: run-webkit-tests http/tests/ssl/applepay/ApplePayBillingAddress.html --iterations 5000 exit-after-n-failures 5 --force -f
Comment 3 Ryan Haddad 2020-02-11 13:17:52 PST
This test was added with https://trac.webkit.org/changeset/256041/webkit:
[Apple Pay] Provide a redacted billing contact during payment method selection
​https://bugs.webkit.org/show_bug.cgi?id=207169
<rdar://problem/42737441>
Comment 4 Ryan Haddad 2020-02-11 13:25:57 PST
<rdar://problem/59360124>
Comment 5 Nikos Mouchtaris 2020-02-11 16:49:13 PST
Created attachment 390467 [details]
Patch
Comment 6 Wenson Hsieh 2020-02-11 17:10:38 PST
Comment on attachment 390467 [details]
Patch

r=mews
Comment 7 WebKit Commit Bot 2020-02-12 10:57:26 PST
Comment on attachment 390467 [details]
Patch

Clearing flags on attachment: 390467

Committed r256456: <https://trac.webkit.org/changeset/256456>
Comment 8 WebKit Commit Bot 2020-02-12 10:57:28 PST
All reviewed patches have been landed.  Closing bug.