Bug 207360 - Allow UIDNAInfo.errors from uidna_nameToUnicode that would not cause URL parsing failures
Summary: Allow UIDNAInfo.errors from uidna_nameToUnicode that would not cause URL pars...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Template Framework (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alex Christensen
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-02-06 14:51 PST by Alex Christensen
Modified: 2020-02-14 11:10 PST (History)
8 users (show)

See Also:


Attachments
patch (3.36 KB, patch)
2020-02-06 14:59 PST, Alex Christensen
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from webkit-cq-03 for mac-mojave (4.23 MB, application/zip)
2020-02-06 18:52 PST, WebKit Commit Bot
no flags Details
Patch (3.45 KB, patch)
2020-02-14 10:21 PST, Alex Christensen
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Christensen 2020-02-06 14:51:30 PST
There are some error codes in the UIDNAInfo used by uidna_nameToUnicode that should not cause domain decoding failures.  I allow the ones that are caused by strings that would parse successfully in URLParser, which uses uidna_nameToASCII.
Comment 1 Alex Christensen 2020-02-06 14:59:40 PST
Created attachment 390007 [details]
patch
Comment 2 WebKit Commit Bot 2020-02-06 18:36:56 PST
The commit-queue encountered the following flaky tests while processing attachment 390007 [details]:

editing/spelling/spellcheck-async-remove-frame.html bug 158401 (authors: morrita@google.com, rniwa@webkit.org, and tony@chromium.org)
The commit-queue is continuing to process your patch.
Comment 3 WebKit Commit Bot 2020-02-06 18:36:57 PST
The commit-queue encountered the following flaky tests while processing attachment 390007 [details]:

The commit-queue is continuing to process your patch.
Comment 4 WebKit Commit Bot 2020-02-06 18:51:58 PST
Comment on attachment 390007 [details]
patch

Rejecting attachment 390007 [details] from commit-queue.

New failing tests:
fast/encoding/idn-security.html
Full output: https://webkit-queues.webkit.org/results/13318240
Comment 5 WebKit Commit Bot 2020-02-06 18:52:00 PST
Created attachment 390043 [details]
Archive of layout-test-results from webkit-cq-03 for mac-mojave

The attached test failures were seen while running run-webkit-tests on the commit-queue.
Bot: webkit-cq-03  Port: mac-mojave  Platform: Mac OS X 10.14.6
Comment 6 Alex Christensen 2020-02-14 10:21:23 PST
I'm allowing errors for uidna_nameToUnicode, not uidna_nameToASCII.  That fixes the test.
Comment 7 Alex Christensen 2020-02-14 10:21:55 PST
Created attachment 390783 [details]
Patch
Comment 8 WebKit Commit Bot 2020-02-14 11:09:38 PST
Comment on attachment 390783 [details]
Patch

Clearing flags on attachment: 390783

Committed r256629: <https://trac.webkit.org/changeset/256629>
Comment 9 WebKit Commit Bot 2020-02-14 11:09:39 PST
All reviewed patches have been landed.  Closing bug.
Comment 10 Radar WebKit Bug Importer 2020-02-14 11:10:20 PST
<rdar://problem/59465075>