Bug 207230 - [ macOS iOS ] imported/w3c/web-platform-tests/fetch/stale-while-revalidate/fetch.html is flaky failing
Summary: [ macOS iOS ] imported/w3c/web-platform-tests/fetch/stale-while-revalidate/fe...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-02-04 14:53 PST by Jacob Uphoff
Modified: 2020-04-24 02:35 PDT (History)
4 users (show)

See Also:


Attachments
Update Test Expectations (2.49 KB, patch)
2020-02-04 14:59 PST, Jacob Uphoff
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jacob Uphoff 2020-02-04 14:53:26 PST
imported/w3c/web-platform-tests/fetch/stale-while-revalidate/fetch.html

This test has been flaky failing since around commit 253788 but I don't believe that is the regression point. 

History:

https://results.webkit.org/?suite=layout-tests&test=imported%2Fw3c%2Fweb-platform-tests%2Ffetch%2Fstale-while-revalidate%2Ffetch.html&limit=50000&platform=ios&platform=mac

Diff:

--- /Volumes/Data/slave/mojave-release-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/fetch/stale-while-revalidate/fetch-expected.txt
+++ /Volumes/Data/slave/mojave-release-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/fetch/stale-while-revalidate/fetch-actual.txt
@@ -1,3 +1,3 @@
 
-PASS Second fetch returns same response 
+FAIL Second fetch returns same response assert_equals: expected "rhnoxgolpvmficveyrwa" but got "pspjirmlkuuavfcswiee"
Comment 1 Radar WebKit Bug Importer 2020-02-04 14:54:56 PST
<rdar://problem/59166684>
Comment 2 Jacob Uphoff 2020-02-04 14:59:53 PST
Created attachment 389714 [details]
Update Test Expectations
Comment 3 Truitt Savell 2020-02-04 15:02:48 PST
Comment on attachment 389714 [details]
Update Test Expectations

Clearing flags on attachment: 389714

Committed r255704: <https://trac.webkit.org/changeset/255704>
Comment 4 Rob Buis 2020-04-24 02:35:37 PDT
This should be fixed by https://bugs.webkit.org/show_bug.cgi?id=210905.