Bug 207189 - REGRESSION(r255595): page not closed after beforeunload handler returns true
Summary: REGRESSION(r255595): page not closed after beforeunload handler returns true
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-02-04 01:48 PST by Carlos Garcia Campos
Modified: 2020-02-05 10:09 PST (History)
7 users (show)

See Also:


Attachments
Fix (1.99 KB, patch)
2020-02-04 01:52 PST, Carlos Garcia Campos
no flags Details | Formatted Diff | Diff
API Test (3.89 KB, patch)
2020-02-04 08:40 PST, Chris Dumez
no flags Details | Formatted Diff | Diff
API test (3.64 KB, patch)
2020-02-04 08:54 PST, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2020-02-04 01:48:58 PST
We are assuming the try close did timeout in that case, because the timer is stopped before running the beforeunload dialog.
Comment 1 Carlos Garcia Campos 2020-02-04 01:52:16 PST
Created attachment 389641 [details]
Fix
Comment 2 Chris Dumez 2020-02-04 08:12:45 PST
Comment on attachment 389641 [details]
Fix

Should have a test but I will follow-up.
Comment 3 Chris Dumez 2020-02-04 08:17:47 PST
Comment on attachment 389641 [details]
Fix

Clearing flags on attachment: 389641

Committed r255677: <https://trac.webkit.org/changeset/255677>
Comment 4 Chris Dumez 2020-02-04 08:17:48 PST
All reviewed patches have been landed.  Closing bug.
Comment 5 Radar WebKit Bug Importer 2020-02-04 08:18:15 PST
<rdar://problem/59149593>
Comment 6 Chris Dumez 2020-02-04 08:38:57 PST
Reopening for API test.
Comment 7 Chris Dumez 2020-02-04 08:40:08 PST
Created attachment 389664 [details]
API Test
Comment 8 Chris Dumez 2020-02-04 08:54:50 PST
Created attachment 389667 [details]
API test
Comment 9 Chris Dumez 2020-02-05 09:08:16 PST
Comment on attachment 389667 [details]
API test

Ping review?
Comment 10 Chris Dumez 2020-02-05 10:08:59 PST
Comment on attachment 389667 [details]
API test

Clearing flags on attachment: 389667

Committed r255826: <https://trac.webkit.org/changeset/255826>
Comment 11 Chris Dumez 2020-02-05 10:09:02 PST
All reviewed patches have been landed.  Closing bug.