Bug 207171 - WebKit doesn't support install prompt customization
Summary: WebKit doesn't support install prompt customization
Status: RESOLVED DUPLICATE of bug 193959
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: Safari 13
Hardware: iPhone / iPad iOS 13
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-03 17:41 PST by Alvin Portillo
Modified: 2020-02-04 01:08 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alvin Portillo 2020-02-03 17:41:11 PST
WebKit does not currently support the `beforeinstallprompt` event, leaving developers without a solution to build install prompts custom to their web apps.

I've read through https://github.com/w3c/manifest/issues/835, and I understand the concerns around lowering the signal of explicit user intent when websites are allowed to prompt for installation on page load (similar to how many sites handle push notifications). Though I'd really like to highlight concerns around user privacy when customization of these prompts is not supported in any way.

It is better, and sometimes legally required, to inform the user in understandable terms what they are agreeing to. Typically, these standalone web apps offer users offline support. This may require persisting data across multiple sessions; something that a user may not have agreed to by tapping Safari's "Add to Homescreen" button. 

My understanding is that the WebKit team is against implementing the current `beforeinstallprompt` event spec, though without a replacement, it disincentivizes both developers to build these experiences and users to use these experiences.
Comment 1 Ryosuke Niwa 2020-02-04 00:55:54 PST

*** This bug has been marked as a duplicate of bug 193959 ***