Bug 207120 - [ macOS wk2 ] tiled-drawing/scrolling/scroll-snap/scroll-snap-mandatory-then-proximity.html is flaky failing
Summary: [ macOS wk2 ] tiled-drawing/scrolling/scroll-snap/scroll-snap-mandatory-then-...
Status: RESOLVED DUPLICATE of bug 197819
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-02-03 08:48 PST by Jacob Uphoff
Modified: 2020-03-21 12:03 PDT (History)
4 users (show)

See Also:


Attachments
Update Test Expectations (1.46 KB, patch)
2020-02-03 09:01 PST, Jacob Uphoff
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jacob Uphoff 2020-02-03 08:48:21 PST
tiled-drawing/scrolling/scroll-snap/scroll-snap-mandatory-then-proximity.html

This test has been a flaky failure for all visible history on Catalina and Mojave 

I ran this test in iterations and did not reproduce the failure

History:

https://results.webkit.org/?limit=50000&suite=layout-tests&test=tiled-drawing%2Fscrolling%2Fscroll-snap%2Fscroll-snap-mandatory-then-proximity.html

Diff:

--- /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/tiled-drawing/scrolling/scroll-snap/scroll-snap-mandatory-then-proximity-expected.txt
+++ /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/tiled-drawing/scrolling/scroll-snap/scroll-snap-mandatory-then-proximity-actual.txt
@@ -2,6 +2,6 @@
 - Did the scrolling snap to the top? NO
 - Did scrolling snap to the second box? YES
 Scrolling in container with scroll-snap-type: y proximity
-- Did the scrolling snap to the top? NO
+- Did the scrolling snap to the top? YES
 - Did scrolling snap to the second box? NO
Comment 1 Radar WebKit Bug Importer 2020-02-03 08:48:46 PST
<rdar://problem/59111700>
Comment 2 Jacob Uphoff 2020-02-03 09:01:39 PST
Created attachment 389522 [details]
Update Test Expectations
Comment 3 Truitt Savell 2020-02-03 09:02:58 PST
Comment on attachment 389522 [details]
Update Test Expectations

Clearing flags on attachment: 389522

Committed r255565: <https://trac.webkit.org/changeset/255565>
Comment 4 Simon Fraser (smfr) 2020-03-21 12:03:47 PDT
No longer flakey. Expectation removed in r258701.

*** This bug has been marked as a duplicate of bug 197819 ***