Bug 206864 - JSC 32bits is failing on new test stress/numberingSystemsForLocale-cached-strings-should-be-immortal-and-safe-for-concurrent-access.js
Summary: JSC 32bits is failing on new test stress/numberingSystemsForLocale-cached-str...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Paulo Matos
URL:
Keywords: InRadar
: 206869 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-27 23:25 PST by Paulo Matos
Modified: 2020-03-10 02:20 PDT (History)
5 users (show)

See Also:


Attachments
Patch (1.89 KB, patch)
2020-03-09 04:48 PDT, Paulo Matos
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Paulo Matos 2020-01-27 23:25:26 PST
Test introduced in r255112 crashes JSC32 bits and needs to be investigated.
Comment 1 Paulo Matos 2020-01-27 23:37:07 PST
Test removed in bug 206865.
Comment 2 Paulo Matos 2020-01-27 23:37:21 PST
(In reply to Paulo Matos from comment #1)
> Test removed in bug 206865.

s/removed/skipped/
Comment 3 Caio Lima 2020-01-28 09:30:19 PST
*** Bug 206869 has been marked as a duplicate of this bug. ***
Comment 4 Caio Lima 2020-01-29 04:25:33 PST
For the record see https://bugs.webkit.org/show_bug.cgi?id=206869#c6 before investigating this. Skipping this permanently might be the right solution.
Comment 5 Paulo Matos 2020-03-09 03:23:59 PDT
The tests pass on arm and mips for 25 threads but fail for 100. I wonder if we should have the same tests but generating only 25 threads for memory limited machines.
Comment 6 Paulo Matos 2020-03-09 04:48:53 PDT
Created attachment 393021 [details]
Patch
Comment 7 Yusuke Suzuki 2020-03-10 01:35:09 PDT
Comment on attachment 393021 [details]
Patch

r=me
Comment 8 WebKit Commit Bot 2020-03-10 02:19:52 PDT
Comment on attachment 393021 [details]
Patch

Clearing flags on attachment: 393021

Committed r258190: <https://trac.webkit.org/changeset/258190>
Comment 9 WebKit Commit Bot 2020-03-10 02:19:53 PDT
All reviewed patches have been landed.  Closing bug.
Comment 10 Radar WebKit Bug Importer 2020-03-10 02:20:13 PDT
<rdar://problem/60265849>