Bug 206685 - [macOS iOS ] animations/animation-direction-normal.html is flaky failing
Summary: [macOS iOS ] animations/animation-direction-normal.html is flaky failing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Animations (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-01-23 11:23 PST by Jacob Uphoff
Modified: 2020-03-18 08:59 PDT (History)
7 users (show)

See Also:


Attachments
Update Test Expectations (2.70 KB, patch)
2020-01-27 15:34 PST, Jacob Uphoff
no flags Details | Formatted Diff | Diff
Update Test Expectations (2.80 KB, patch)
2020-01-27 15:44 PST, Jacob Uphoff
no flags Details | Formatted Diff | Diff
Patch (5.63 KB, patch)
2020-03-18 07:06 PDT, Antoine Quint
no flags Details | Formatted Diff | Diff
Patch (4.95 KB, patch)
2020-03-18 07:13 PDT, Antoine Quint
koivisto: review+
commit-queue: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jacob Uphoff 2020-01-23 11:23:29 PST
animations/animation-direction-normal.html is flaky failing across all platforms tested

I did not try to reproduce the failure

History:
https://results.webkit.org/?suite=layout-tests&test=animations%2Fanimation-direction-normal.html

diff:

--- /Volumes/Data/slave/catalina-debug-tests-wk1/build/layout-test-results/animations/animation-direction-normal-expected.txt
+++ /Volumes/Data/slave/catalina-debug-tests-wk1/build/layout-test-results/animations/animation-direction-normal-actual.txt
@@ -1,4 +1,4 @@
-PASS - "webkitTransform" property for "box" element at 0.5s saw something close to: 1,0,0,1,50,0
+FAIL - "webkitTransform" property for "box" element at 0.5s expected: 1,0,0,1,50,0 but saw: matrix(1, 0, 0, 1, 73.4000015258789, 0)
 PASS - "webkitTransform" property for "box" element at 1s saw something close to: 1,0,0,1,100,0
 PASS - "webkitTransform" property for "box" element at 2.5s saw something close to: 1,0,0,1,50,0
Comment 1 Radar WebKit Bug Importer 2020-01-23 11:24:02 PST
<rdar://problem/58841791>
Comment 2 Truitt Savell 2020-01-23 15:39:16 PST
It looks like this test first failed around r251441
Comment 3 Alexey Proskuryakov 2020-01-26 13:22:37 PST
This is quite an unusual pattern - this test has periods of 100% reliability, and periods where it fails super frequently.
Comment 4 Jacob Uphoff 2020-01-27 15:34:06 PST
Created attachment 388927 [details]
Update Test Expectations
Comment 5 Jacob Uphoff 2020-01-27 15:44:41 PST
Created attachment 388930 [details]
Update Test Expectations
Comment 6 Truitt Savell 2020-01-27 15:48:43 PST
Comment on attachment 388930 [details]
Update Test Expectations

Clearing flags on attachment: 388930

Committed r255190: <https://trac.webkit.org/changeset/255190>
Comment 7 Antoine Quint 2020-03-18 07:06:15 PDT
Created attachment 393846 [details]
Patch
Comment 8 Antoine Quint 2020-03-18 07:13:39 PDT
Created attachment 393848 [details]
Patch
Comment 9 WebKit Commit Bot 2020-03-18 08:55:19 PDT
Comment on attachment 393848 [details]
Patch

Rejecting attachment 393848 [details] from commit-queue.

Failed to run "['/Volumes/Data/EWS/WebKit/Tools/Scripts/webkit-patch', '--status-host=webkit-queues.webkit.org', '--bot-id=webkit-cq-03', 'land-attachment', '--force-clean', '--non-interactive', '--parent-command=commit-queue', 393848, '--port=mac']" exit_code: 2 cwd: /Volumes/Data/EWS/WebKit

Logging in as commit-queue@webkit.org...
Fetching: https://bugs.webkit.org/attachment.cgi?id=393848&action=edit
Fetching: https://bugs.webkit.org/show_bug.cgi?id=206685&ctype=xml&excludefield=attachmentdata
Processing 1 patch from 1 bug.
Updating working directory
Processing patch 393848 from bug 206685.
Fetching: https://bugs.webkit.org/attachment.cgi?id=393848
Failed to run "[u'/Volumes/Data/EWS/WebKit/Tools/Scripts/svn-apply', '--force', '--reviewer', u'Antti Koivisto']" exit_code: 1 cwd: /Volumes/Data/EWS/WebKit

Parsed 5 diffs from patch file(s).
patching file LayoutTests/ChangeLog
Hunk #1 succeeded at 1 with fuzz 3.
patching file LayoutTests/animations/animation-direction-normal-expected.txt
patching file LayoutTests/animations/animation-direction-normal.html
patching file LayoutTests/platform/ios-wk2/TestExpectations
patching file LayoutTests/platform/mac/TestExpectations
Hunk #1 FAILED at 1911.
1 out of 1 hunk FAILED -- saving rejects to file LayoutTests/platform/mac/TestExpectations.rej

Failed to run "[u'/Volumes/Data/EWS/WebKit/Tools/Scripts/svn-apply', '--force', '--reviewer', u'Antti Koivisto']" exit_code: 1 cwd: /Volumes/Data/EWS/WebKit

Parsed 5 diffs from patch file(s).
patching file LayoutTests/ChangeLog
Hunk #1 succeeded at 1 with fuzz 3.
patching file LayoutTests/animations/animation-direction-normal-expected.txt
patching file LayoutTests/animations/animation-direction-normal.html
patching file LayoutTests/platform/ios-wk2/TestExpectations
patching file LayoutTests/platform/mac/TestExpectations
Hunk #1 FAILED at 1911.
1 out of 1 hunk FAILED -- saving rejects to file LayoutTests/platform/mac/TestExpectations.rej

Failed to run "[u'/Volumes/Data/EWS/WebKit/Tools/Scripts/svn-apply', '--force', '--reviewer', u'Antti Koivisto']" exit_code: 1 cwd: /Volumes/Data/EWS/WebKit
Updating OpenSource
From https://git.webkit.org/git/WebKit
   0c3fd4b60bd..2d55aaccfdd  master     -> origin/master
Partial-rebuilding .git/svn/refs/remotes/origin/master/.rev_map.268f45cc-cd09-0410-ab3c-d52691b4dbfc ...
Currently at 258632 = 0c3fd4b60bdae791e930955ebadd94e3f1c0a147
r258633 = 4976356e439e0e454491be6d1518fee37d19bfd3
r258634 = aeb81dbf190cad11b45f2419f12dce5e13b09592
r258635 = a7dd63f3e208ea06c74b45cd941e2e4bcec4c6d1
r258636 = 5470f02f13f0fb30d8213891e61cbdc14b9c3bd1
r258637 = 67ce0a2340c0263e2e11d3149c94fd7d4c3a962a
r258638 = 2d55aaccfdd87b7b2adbd9386e82a99eb4c6b66b
Done rebuilding .git/svn/refs/remotes/origin/master/.rev_map.268f45cc-cd09-0410-ab3c-d52691b4dbfc
First, rewinding head to replay your work on top of it...
Fast-forwarded master to refs/remotes/origin/master.

Full output: https://webkit-queues.webkit.org/results/13343746
Comment 10 Antoine Quint 2020-03-18 08:59:12 PDT
Committed r258639: <https://trac.webkit.org/changeset/258639>