Bug 206624 - REGRESSION: [ Mac ] legacy-animation-engine/fast/animation/request-animation-frame-iframe2.html is a flaky failure
Summary: REGRESSION: [ Mac ] legacy-animation-engine/fast/animation/request-animation-...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Animations (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Said Abou-Hallawa
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-01-22 15:57 PST by Jacob Uphoff
Modified: 2020-02-11 03:32 PST (History)
9 users (show)

See Also:


Attachments
Patch (1.85 KB, patch)
2020-01-27 11:38 PST, Said Abou-Hallawa
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jacob Uphoff 2020-01-22 15:57:34 PST
legacy-animation-engine/fast/animation/request-animation-frame-iframe2.html

This is a flakey failure that appears to have started before commit 253106, however because it is so flakey I am not sure when exactly the regression could have been entered in.
I did not try to reproduce the failure, the failures have become more frequent.

History: 
https://results.webkit.org/?suite=layout-tests&test=legacy-animation-engine%2Ffast%2Fanimation%2Frequest-animation-frame-iframe2.html

Diff:

 --- /Volumes/Data/slave/mojave-debug-tests-wk1/build/layout-test-results/legacy-animation-engine/fast/animation/request-animation-frame-iframe2-expected.txt
+++ /Volumes/Data/slave/mojave-debug-tests-wk1/build/layout-test-results/legacy-animation-engine/fast/animation/request-animation-frame-iframe2-actual.txt
@@ -3,7 +3,7 @@
 On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
 
 
-PASS callbackInvoked is true
+FAIL callbackInvoked should be true. Was false.
 PASS mainFrameCallbackInvoked is true
 PASS successfullyParsed is true
Comment 1 Radar WebKit Bug Importer 2020-01-22 15:58:15 PST
<rdar://problem/58814713>
Comment 2 Said Abou-Hallawa 2020-01-27 11:38:44 PST
Created attachment 388877 [details]
Patch
Comment 3 WebKit Commit Bot 2020-02-11 03:32:02 PST
Comment on attachment 388877 [details]
Patch

Clearing flags on attachment: 388877

Committed r256300: <https://trac.webkit.org/changeset/256300>
Comment 4 WebKit Commit Bot 2020-02-11 03:32:04 PST
All reviewed patches have been landed.  Closing bug.