Bug 20662 - debian patches for webkit 1.0.1 (their versioning)
Summary: debian patches for webkit 1.0.1 (their versioning)
Status: RESOLVED DUPLICATE of bug 19775
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on: 19775 19910
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 05:34 PDT by Luke Kenneth Casson Leighton
Modified: 2012-02-20 15:09 PST (History)
6 users (show)

See Also:


Attachments
debian 1.0.1 downstream patches (7.91 KB, patch)
2008-09-05 05:34 PDT, Luke Kenneth Casson Leighton
no flags Details | Formatted Diff | Diff
debian 1.1.13 downstream patch (4.37 KB, patch)
2009-08-24 22:10 PDT, Mike Hommey
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Kenneth Casson Leighton 2008-09-05 05:34:31 PDT
folks, hi,
debian has some strange patches for ARM and other stuff, which i thought best to attach to make sure none of them have been missed.  they're quite small and trivial but highly significant for various architectures.
Comment 1 Luke Kenneth Casson Leighton 2008-09-05 05:34:56 PDT
Created attachment 23189 [details]
debian 1.0.1 downstream patches
Comment 2 Alexey Proskuryakov 2008-09-08 03:47:56 PDT
It's good to have these available for reference, but to get them landed, we'd obviously need to split and categorize the changes, write ChangeLogs etc.
Comment 3 Jan Alonzo 2008-10-25 00:26:58 PDT
(CC'ing Mike Hommey)

Mike: do you know which ones should go upstream and which ones shouldn't?
Comment 4 Mike Hommey 2008-10-25 00:45:34 PDT
(In reply to comment #3)
> (CC'ing Mike Hommey)
> 
> Mike: do you know which ones should go upstream and which ones shouldn't?

Most of it is already in another bug, IIRC. I'll try to find out where it is.
Anyways, I'm currently merging current trunk in and updating the whole thing, so I'll keep you posted.
Comment 5 Mike Hommey 2008-10-25 02:30:21 PDT
So, to take it down:
debian/control is debian specific

WebCore/platform/text/AtomicString.cpp,
WebCore/platform/text/StringHash.h,
JavaScriptCore/wtf/Platform.h,
JavaScriptCore/wtf/ListHashSet.h,
JavaScriptCore/wtf/Vector.h,
JavaScriptCore/wtf/FastMalloc.cpp: These are in bug #19775. While the fix is okay for debian, it is not for webkit without rework

WebCore/platform/graphics/BitmapImage.cpp,
WebCore/platform/graphics/cg/ImageCG.cpp,
WebCore/platform/graphics/cairo/ImageCairo.cpp: Cherry-pick from svn revision 34625.

WebCore/page/gtk/AXObjectCacheAtk.cpp: Fix specific to 1.0.1 release tarball. See bug #19910

Comment 6 Eric Seidel (no email) 2009-08-24 15:13:58 PDT
I noticed this bug this afternoon.  Is there still stuff to do here or should we close this?  It's been a year since the last activity.
Comment 7 Mike Hommey 2009-08-24 22:10:34 PDT
Created attachment 38525 [details]
debian 1.1.13 downstream patch

We still use a part of the patch that was uploaded here. Here are the changes we have against 1.1.13 released yesterday.
Comment 8 Mike Hommey 2009-08-24 22:13:51 PDT
Note this patch is roughly what is in bug 19775.
Comment 9 Eric Seidel (no email) 2009-08-25 00:31:55 PDT
Ok.  That will need to be split up into separate patches and ChangeLogs added of course. :)
Comment 10 Mike Hommey 2009-08-25 10:55:10 PDT
(In reply to comment #9)
> Ok.  That will need to be split up into separate patches and ChangeLogs added
> of course. :)

If I'm not mistaken, the whole patch is to address bug 19775, though some changes in the webkit code made one of the changes affect arm as well.
Comment 11 Gustavo Noronha (kov) 2012-02-20 15:09:39 PST
This bug is actually obsolete for a while. We no longer carry most of these changes.

*** This bug has been marked as a duplicate of bug 19775 ***