Bug 20641 - REGRESSION: Crash in GlyphPage::fill on more complex mapping applications
Summary: REGRESSION: Crash in GlyphPage::fill on more complex mapping applications
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P1 Critical
Assignee: Nobody
URL: http://www.carto.net/williams/yosemite/
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2008-09-04 02:07 PDT by Andreas Neumann
Modified: 2008-10-02 23:11 PDT (History)
5 users (show)

See Also:


Attachments
Crashlog of the Yosemite Mapping Example (23.62 KB, text/plain)
2008-09-04 02:10 PDT, Andreas Neumann
no flags Details
Crashlog of the Geophoto Mapping Example (23.90 KB, text/plain)
2008-09-04 02:10 PDT, Andreas Neumann
no flags Details
Crashlog of the Yosemite Example, G4 Powerbook Tiger (22.27 KB, text/plain)
2008-09-08 11:08 PDT, Andreas Neumann
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Neumann 2008-09-04 02:07:53 PDT
On some of my more complex SVG mapping examples I get crashes with the current nightlies.

Here are two URLs where I get the crashes:
http://www.carto.net/williams/yosemite/
http://www.geofoto.ch/geophotomap/

It is hard to isolate the problem, but maybe someone could read something from the crash-logs. I can certainly help to investigate the problem with your help.

Thanks for having a look at these two examples.
Comment 1 Andreas Neumann 2008-09-04 02:10:04 PDT
Created attachment 23160 [details]
Crashlog of the Yosemite Mapping Example
Comment 2 Andreas Neumann 2008-09-04 02:10:51 PDT
Created attachment 23161 [details]
Crashlog of the Geophoto Mapping Example
Comment 3 Eric Seidel (no email) 2008-09-04 02:18:47 PDT
Seems we're passing bad stuff off into the font system.
Comment 4 Mark Rowe (bdash) 2008-09-04 02:34:59 PDT
<rdar://problem/6195656>
Comment 5 Bruce Rindahl 2008-09-04 05:43:09 PDT
I am not seeing this bug yet on windows r36012.  Maybe it happened after this nightly.  I will check when the next windows build is posted.
Comment 6 Andreas Neumann 2008-09-04 05:50:07 PDT
could be that it only happens on Mac? The bug has been around for a while on my machine, but I only reported it now.

The SVG fonts might be an issue. Both examples use SVG fonts.

(In reply to comment #5)
> I am not seeing this bug yet on windows r36012.  Maybe it happened after this
> nightly.  I will check when the next windows build is posted.
> 
Comment 7 Alexey Proskuryakov 2008-09-08 03:12:09 PDT
I cannot reproduce this with a local build of r36264 - but from the looks of the crash log, the problem may easily be Tiger-only.
Comment 8 Andreas Neumann 2008-09-08 11:07:05 PDT
I was just testing the issue on a G4 Powerbook, also Tiger. It also crashes. I will also submit the crashlog from the G4.
Comment 9 Andreas Neumann 2008-09-08 11:08:11 PDT
Created attachment 23268 [details]
Crashlog of the Yosemite Example, G4 Powerbook Tiger
Comment 10 mitz 2008-09-08 12:09:22 PDT
Any idea when the regression occurred?
Comment 11 Andreas Neumann 2008-09-08 12:11:55 PDT
I don't know when it appeared.

I know that it is at least 3 weeks old - but it may be older. I was busy back then and did not do a lot of testing.
Comment 12 Eric Seidel (no email) 2008-10-02 12:56:02 PDT
I'm not able to reproduce this.
Comment 13 Alexey Proskuryakov 2008-10-02 13:15:39 PDT
I couldn't reproduce the crash in a few minutes of testing on Tiger either. But please feel free to re-open if this still happens to you. You may want to clear OS font caches and/or to try from a different user account, too.
Comment 14 Andreas Neumann 2008-10-02 13:44:45 PDT
(In reply to comment #13)

indeed it only appears on one user account. When logging in with another (fresh) user account, the problem does not appear - also, meanwhile I have Leopard on the machine and Tiger now on an external disk. On Leopard (with a new user account) the problem doesn't appear either.

How do I empty the OS font-cache?

> I couldn't reproduce the crash in a few minutes of testing on Tiger either. But
> please feel free to re-open if this still happens to you. You may want to clear
> OS font caches and/or to try from a different user account, too.
> 
Comment 15 Alexey Proskuryakov 2008-10-02 23:11:50 PDT
(In reply to comment #14)
> How do I empty the OS font-cache?

I'd just delete everything in ~/Library/Caches, /Library/Caches, and /System/Library/Caches, and reboot. But there are multiple "cache cleaner" utilities with nice GUIs to be found on MacUpdate or VersionTracker.