Bug 206254 - REGRESSION: [ Mac ] fast/hidpi/image-srcset-relative-svg-canvas-2x.html is a flaky failure
Summary: REGRESSION: [ Mac ] fast/hidpi/image-srcset-relative-svg-canvas-2x.html is a ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Images (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: zalan
URL:
Keywords: InRadar
: 206211 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-14 13:54 PST by Truitt Savell
Modified: 2020-01-30 04:59 PST (History)
5 users (show)

See Also:


Attachments
Archive of layout-test-results from webkit-cq-03 (3.30 MB, application/zip)
2020-01-18 11:28 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from webkit-cq-01 (3.24 MB, application/zip)
2020-01-27 17:44 PST, WebKit Commit Bot
no flags Details
Patch (2.43 KB, patch)
2020-01-28 16:43 PST, zalan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Truitt Savell 2020-01-14 13:54:18 PST
fast/hidpi/image-srcset-relative-svg-canvas-2x.html

Description:
This test has been a flaky failure on Mac sense around r252143. This diff is a difference of the size of a purple circle.

History:
https://results.webkit.org/?suite=layout-tests&test=fast%2Fhidpi%2Fimage-srcset-relative-svg-canvas-2x.html

Diff:
https://build.webkit.org/results/Apple-Catalina-Release-WK1-Tests/r254526%20(2141)/fast/hidpi/image-srcset-relative-svg-canvas-2x-diffs.html
Comment 1 Radar WebKit Bug Importer 2020-01-14 13:54:33 PST
<rdar://problem/58580461>
Comment 2 Truitt Savell 2020-01-14 14:06:35 PST
I am able to reproduce this locally on tot by just running the test in iterations
Comment 3 Alexey Proskuryakov 2020-01-14 22:53:30 PST
*** Bug 206211 has been marked as a duplicate of this bug. ***
Comment 4 WebKit Commit Bot 2020-01-18 11:28:25 PST
The commit-queue just saw fast/hidpi/image-srcset-relative-svg-canvas-2x.html flake (image diff) while processing attachment 388151 [details] on bug 206473.
Bot: webkit-cq-03  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.14.6
Comment 5 WebKit Commit Bot 2020-01-18 11:28:26 PST
Created attachment 388157 [details]
Archive of layout-test-results from webkit-cq-03
Comment 6 WebKit Commit Bot 2020-01-27 17:44:53 PST
The commit-queue just saw fast/hidpi/image-srcset-relative-svg-canvas-2x.html flake (image diff) while processing attachment 378671 [details] on bug 201737.
Bot: webkit-cq-01  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.14.6
Comment 7 WebKit Commit Bot 2020-01-27 17:44:54 PST
Created attachment 388950 [details]
Archive of layout-test-results from webkit-cq-01
Comment 8 zalan 2020-01-28 16:43:36 PST
Created attachment 389087 [details]
Patch
Comment 9 WebKit Commit Bot 2020-01-28 17:57:30 PST
Comment on attachment 389087 [details]
Patch

Clearing flags on attachment: 389087

Committed r255331: <https://trac.webkit.org/changeset/255331>
Comment 10 WebKit Commit Bot 2020-01-28 17:57:32 PST
All reviewed patches have been landed.  Closing bug.