Bug 206219 - [HTML5 App] Using <input> to call the device camera returns a blank screen after leaving the App.
Summary: [HTML5 App] Using <input> to call the device camera returns a blank screen af...
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: Safari 13
Hardware: iPhone / iPad iOS 13
: P1 Normal
Assignee: Nobody
Keywords: InRadar
Depends on:
Reported: 2020-01-14 02:32 PST by marcus
Modified: 2020-07-14 02:20 PDT (History)
14 users (show)

See Also:

HTML5 App Camera bug test (371 bytes, text/html)
2020-01-14 02:50 PST, marcus
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description marcus 2020-01-14 02:32:10 PST
Hi All,

Issue: When using the following <input> tag to call the camera to take an image to upload in a Standalone application;
<input type="file" name="media" id="media" accept="image/*;capture=camera" multiple="">

Upon first invoking this; the camera works as normal and displays the result allowing to take a picture.
When leaving the app and waiting a period of ~5 seconds, and returning, calling the same <input> tab returns a blank camera output and refuses to take an image.

Reloading the page via any method does not correct the issue; only force quitting from multitasking allows the camera to work again.

Recent reports of this exact same behaviour can be found in the following overflow threads;




Personally I need this functionality to work as I'm designing a receipt management system for use with my universities societies that provides the same UI/Functions as if they were viewing it on a desktop (hence HTML5 App.)

Any feedback would be greatly appreciated !
Comment 1 marcus 2020-01-14 02:49:41 PST
Uploaded a very basic test environment to install as a HTML5 App to reproduce the issue.
Comment 2 marcus 2020-01-14 02:50:26 PST
Created attachment 387640 [details]
HTML5 App Camera bug test
Comment 3 Blake Yeager 2020-01-14 16:55:03 PST
We have been experiencing this exact same issue with our PWA (standalone application) with our customers running on iOS 13.2 or 13.3.

Any time we attempt to access the camera after having closed the app and reopened it the camera interface loads, but there is just a black screen with no video feed from the camera. There are camera controls on the top and bottom but capturing an image does not work. This behavior happens the second time you open the app and attempt to use the camera regardless of whether or not you accessed the camera the first time you opened the app.

The only fix we have found for this issue has been swiping up on the app placeholder in the app switcher.

This functionality is critical for our standalone application. I would appreciate any suggestions for potential workarounds or even confirmation from someone who might know what exactly is going on here.

Comment 4 Radar WebKit Bug Importer 2020-01-14 22:51:24 PST
Comment 5 tjyoung 2020-01-21 09:26:43 PST
Yes i've noticed that as well. thats a 'new' feature
Comment 6 Doodle Labs 2020-01-24 05:21:17 PST
We have also seen this issue with one of our PWAs and we desperately need it fixing as it is having a huge impact on our customers user experience.
Comment 7 marcus 2020-01-28 08:24:48 PST
Okay this behavior has started to appear including but sometimes regardless of if the user has left the application.

I very much feel like this is a regression (as in, this behavior worked before after previously not being able to use the input crafted above), but I'll see what others say before I suggest to mark it as that.
Comment 8 Blake Yeager 2020-01-28 08:52:36 PST
I agree that this is a regression. This behavior was working in previous versions of iOS including 13.1, and only started showing up in either iOS 13.2 or 13.3 (I haven't been able to nail down the exact minor version).
Comment 9 marcus 2020-01-28 09:26:41 PST
Okay I'm going to remark it as a regression, please feel free to undo if this doesn't seem correct; however this behavior has not existed previously from development in any scope.
Comment 10 rud erm 2020-02-07 04:54:06 PST
can anyone check if this still a problem in 13.4 beta?
Comment 11 Louis Ormerod 2020-02-11 11:05:41 PST
It is still a problem in 13.4 beta.  The getUserMedia access to the camera appears to have been fixed in the beta, but this issue (camera capture using input element) is still there. 

It works ok on first access to the camera, but you only get a blank screen when putting the app into the background, and then going back to it.
Comment 12 Blake Yeager 2020-02-20 16:08:23 PST
Does anyone know if there is a more effective way to get the team's attention on this issue? I feel like it hasn't even been acknowledged yet, and it remains a huge issue for us and our customer base. I am not an expert on reporting iOS bugs to Apple, but would it be beneficial to report this directly to Apple?
Comment 13 marcus 2020-02-20 16:55:49 PST
It’s been raised to P1 already, a high priority due to it’s regression from a previous build. So unfortunately that’s all we can really do. You’re free to email the developers in the CC list but I’d recommend against as they probably get enough emails from bug reports as it is. 

Just keep the report alive to show bother is what we can do!
Comment 14 Eric Carlson 2020-02-20 19:06:06 PST
We are aware of the problem with <input capture> and are continuing to work on a fix.

Thanks for the reports/reminders!
Comment 15 Jan 2020-02-23 09:25:09 PST
It seems that in iOS 13.4 beta 2 the problem is solved!
Comment 16 Timo 2020-07-14 02:20:45 PDT
I can confirm that I and a customer had this exact issue in 13.3, and that it has been resolved after updating to 13.5.1

Thank you to the people reporting and fixing this issue!