Bug 20599 - REGRESSION: Important controls are missing from <video> element UI, when compared to QuickTime
Summary: REGRESSION: Important controls are missing from <video> element UI, when comp...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P1 Normal
Assignee: Nobody
URL: http://youtube.seeqpod.com/m/La%20Ore...
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2008-09-02 04:33 PDT by Iván Garcia
Modified: 2013-06-17 14:51 PDT (History)
17 users (show)

See Also:


Attachments
Patch (10.87 KB, patch)
2013-06-14 15:45 PDT, Ruth Fong
no flags Details | Formatted Diff | Diff
Patch (13.28 KB, patch)
2013-06-14 16:17 PDT, Ruth Fong
no flags Details | Formatted Diff | Diff
Patch (13.28 KB, patch)
2013-06-14 16:26 PDT, Ruth Fong
no flags Details | Formatted Diff | Diff
Patch (19.58 KB, patch)
2013-06-17 11:30 PDT, Ruth Fong
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Iván Garcia 2008-09-02 04:33:59 PDT
When I open a mp3, mp4 or mov file in Webkit (r36013, 1 Sept 08) quicktime plugin is in "Kiosk" mode, when I turned off in Quicktime Preference Pane. 

In this mode I can't download the file (I have QuickTime Pro), I can't change volume (only mute), and Behavior is very bad. Music keeps playing after 5 seconds I closed tab. A capture:
http://img131.imageshack.us/img131/2313/imagen1tv6.png

All this not happen in Standard Safari, mp3 load correctly. A capture:
http://img399.imageshack.us/img399/5493/imagen2fa8.png

This is not only with Seeqpod music. For example:
http://movies.apple.com/movies/paramount/tropic_thunder/tropic_thunder-tlr1a_480p.mov
Doesn't load correctly 

An interesting thing is that is file is embebed plugin loads ok. For example:
http://www.midilifecrisis.com/MortillaDemoReelMacs.html

Works perfectly while other file with the same format (m4v):
http://content.mobuzz.tv/es/dosisdiaria/ipod/es_mag_20080724.m4v
doesn't work.

That's all
Comment 1 Alexey Proskuryakov 2008-09-07 11:29:17 PDT
Giving this the full regression treatment (I haven't attempted to reproduce this though).
Comment 2 Alexey Proskuryakov 2008-10-31 12:43:52 PDT
Confirmed with r38032.
Comment 3 Alexey Proskuryakov 2008-10-31 12:48:33 PDT
<rdar://problem/6336097>
Comment 4 Simon Fraser (smfr) 2009-05-14 20:39:52 PDT
The available controls are different because you're comparing the <video> element (which is used when you load a media file directly, via the MediaDocument), with the QuickTime plug-in.

The <video> element controls do not have affordance for saving the movie. This is by design.
Comment 5 Ruth Fong 2013-06-14 15:45:34 PDT
Created attachment 204740 [details]
Patch
Comment 6 Early Warning System Bot 2013-06-14 15:51:11 PDT
Comment on attachment 204740 [details]
Patch

Attachment 204740 [details] did not pass qt-ews (qt):
Output: http://webkit-queues.appspot.com/results/923058
Comment 7 EFL EWS Bot 2013-06-14 15:54:00 PDT
Comment on attachment 204740 [details]
Patch

Attachment 204740 [details] did not pass efl-ews (efl):
Output: http://webkit-queues.appspot.com/results/890138
Comment 8 Early Warning System Bot 2013-06-14 15:54:10 PDT
Comment on attachment 204740 [details]
Patch

Attachment 204740 [details] did not pass qt-wk2-ews (qt-wk2):
Output: http://webkit-queues.appspot.com/results/921059
Comment 9 EFL EWS Bot 2013-06-14 16:00:49 PDT
Comment on attachment 204740 [details]
Patch

Attachment 204740 [details] did not pass efl-wk2-ews (efl-wk2):
Output: http://webkit-queues.appspot.com/results/920060
Comment 10 Ruth Fong 2013-06-14 16:17:43 PDT
Created attachment 204745 [details]
Patch
Comment 11 Ruth Fong 2013-06-14 16:26:13 PDT
Created attachment 204746 [details]
Patch
Comment 12 EFL EWS Bot 2013-06-14 16:41:22 PDT
Comment on attachment 204746 [details]
Patch

Attachment 204746 [details] did not pass efl-ews (efl):
Output: http://webkit-queues.appspot.com/results/906106
Comment 13 Eric Carlson 2013-06-17 09:01:38 PDT
Comment on attachment 204746 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=204746&action=review

> Source/WebCore/page/ContextMenuController.cpp:258
> +        // FIXME: Some day we should be able to do this from within WebCore.

Please file a bug and reference it in the FIXME.
Comment 14 Ruth Fong 2013-06-17 11:30:17 PDT
Created attachment 204843 [details]
Patch
Comment 15 Ruth Fong 2013-06-17 11:33:47 PDT
(In reply to comment #13)
> (From update of attachment 204746 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=204746&action=review
> 
> > Source/WebCore/page/ContextMenuController.cpp:258
> > +        // FIXME: Some day we should be able to do this from within WebCore.
> 
> Please file a bug and reference it in the FIXME.

Bug 117709 now tracks this issue.
Comment 16 WebKit Commit Bot 2013-06-17 14:51:12 PDT
Comment on attachment 204843 [details]
Patch

Clearing flags on attachment: 204843

Committed r151656: <http://trac.webkit.org/changeset/151656>
Comment 17 WebKit Commit Bot 2013-06-17 14:51:16 PDT
All reviewed patches have been landed.  Closing bug.