Bug 20596 - tabindex returns "undefined" for some elements
Summary: tabindex returns "undefined" for some elements
Status: RESOLVED DUPLICATE of bug 7138
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction, InRadar
Depends on:
Blocks:
 
Reported: 2008-09-02 02:20 PDT by Frederico Caldeira Knabben
Modified: 2009-01-12 15:24 PST (History)
0 users

See Also:


Attachments
TC (552 bytes, text/html)
2008-09-02 02:21 PDT, Frederico Caldeira Knabben
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederico Caldeira Knabben 2008-09-02 02:20:20 PDT
Element.tabIndex returns "undefined" for some elements, like <div>. All other browsers returns some value for it.

For non "focusable" elements (like div), tabIndex should return a negative value (-1) by default (IE returns zero). For "focusable" elements (like input), it should return zero by default

I'm attaching a TC that works well with Firefox and Opera.
Comment 1 Frederico Caldeira Knabben 2008-09-02 02:21:30 PDT
Created attachment 23112 [details]
TC

This TC works well with Firefox and Opera.
Comment 2 Mark Rowe (bdash) 2008-09-03 13:25:24 PDT
<rdar://problem/6194013>
Comment 3 Alice Liu 2008-09-09 10:17:43 PDT
The test case returns expected values with TOT WebKit.  Perhaps the wrong test case was attached, or maybe it was tested against an old version of WebKit.  
Comment 4 Frederico Caldeira Knabben 2008-09-10 00:55:16 PDT
For reference, this is the UA string with which I can still confirm this bug.

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US) AppleWebKit/525.19 (KHTML, like Gecko) Version/3.1.2 Safari/525.21

(Safari 3.1.2 Windows / 525.21)
Comment 5 Darin Adler 2009-01-12 15:24:12 PST
So this is a duplicate of a bug we fixed.
Comment 6 Darin Adler 2009-01-12 15:24:19 PST

*** This bug has been marked as a duplicate of 7138 ***